Alcatel speed-touch USB problem???

Discussion in 'Mac Apps and Mac App Store' started by macbeginner, Nov 20, 2003.

  1. macbeginner macrumors newbie

    Nov 20, 2003
    Hungerford, England
    Alcatel speed-touch USB problem
    Hi everyone, need some assistance here!!

    I installed Panther 10.3 today, or rather upgraded a G4 machine
    with a 9. something OS X? bare with me!

    I had broadband working on the old OS but as soon as I upgrade
    with Panther , all hell breaks loose.

    When I try and install the Speed-Touch drivers, it says they are already installed but continue anyway for a full installation?
    I say yes, then says I must unpug the modem first then install the drivers, so I do that but the same error message keeps coming up.

    When I go to set the modem up , it does not show up in the list?

    I am a Windows XP man(sorry, yet to be converted) hoping to be
    impressed with Panther but not yet.

    I think I need to uninstall the modem drivers, reboot, install drivers then plug modem in, but can anyone tell me where the drivers are to uninstall and how to get there??

    Windows version would be Control Panel/Add/Remove Progs.

    Look forward to hearing from someone

  2. terlga macrumors newbie

    Oct 24, 2003
    Cardiff UK
    Speed touch

    I also have the speed touch modem,
    when i upgraded from 9.2 to os x I needed to download the latest drivers,
    and the same was the case when i upgraded to os X.2 after upgrading to Panther the modem still worked ok so
    i suggest you download the drivers for os X.2 and it should work.
  3. X-Baz macrumors member

    Dec 11, 2002
    Leeds, England
    get rid

    if it's the "frog" light blue/green thing, get rid. my experience with it was purely bad under OS X - kernel panics at random intervals and alcatel (or thomson or whoever is supposed to handle it) simply didn't care. i bought an adsl modem/router that runs through ethernet instead, as it needs no drivers.
  4. Viv macrumors regular

    Sep 11, 2003
    Normandy, France
    This one drove me bonkers! when OS X first came out and it is probably just the same problem installer program this time.

    You must unplug any other USB device when you run the installer!

    Thats it, thats all it is! if you have a printer plugged in or USB hub or anything apart from the keyboard it mucks up the install.

    Give it a try and let us know

  5. macbeginner thread starter macrumors newbie

    Nov 20, 2003
    Hungerford, England
    Speed-Touch Modem

    My thanks to Terry, X-Baz and Viv for your feedback.

    I will certainly take your comments on board and will let you know next week when I get to try them out.

    Viv - I don't think there is a USB cable plugged in(another persons mac) not sure about the keyboard though??

    Terry - I downloaded all the latest 'critical updates' from Apple, but will have to check to see if there are more drivers since the launch of Panther.

    X-Baz- this looks like plan B, and a few others on the web have gone down your route and found it the best way.

    Another idea was the power source - does the mac have the power supply large enough - yes it must do because it was working on the 9.2 OS. And does the modem plug into the mains
    because an external USB hub was mentioned, I'm sure it did.

    Anyway will find out Monday hopefully

    Thanks again


  6. macbeginner thread starter macrumors newbie

    Nov 20, 2003
    Hungerford, England

    Sorry for the delay!

    Drivers fixed the problem in the end and alot of time spent talking
    to BT helpdesk who passed me onto Alcatel who passed me onto website!! Took hours to fix!

    Thanks again for help guys


Share This Page