Aliases and symbolic links in Mac OS X Lion

Discussion in 'Mac OS X Lion (10.7)' started by AjaxUK, Jul 6, 2011.

  1. AjaxUK macrumors newbie

    Joined:
    Jul 1, 2011
    #1
    Hi all,

    I've been testing the Lion developer previews and am now using the GM release.

    Has anyone else noticed the OS doesn't seem to support symbolic links? All of my symlinks have been converted to aliases and even when I try to create a new symlink it appears as an alias.

    The problem here is that preference files that I sync using Dropbox are overwritten as hard files whenever the related app is opened.

    This is very annoying as my Dropbox syncing has effectively stopped working.

    I can't seem to find anyone else experiencing this problem which is greatly confusing.
     
  2. brendo234 macrumors newbie

    Joined:
    Feb 7, 2008
    #2
    I'm experiencing the same problem. Have you found a solution yet?

    This is driving me crazy... I use symlinks to point my Pictures/Music/Movies folders in my home directory to an external drive that I use on my PC as well. It worked fine prior to OS X Lion.

    Anyone else having this problem?
     
  3. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
  4. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #4
    Yep no problems here.. an alias is still an alias (a small file with a reference to a file) and a hard symlink is still there.. a FS-level link.

    Just tried creating an alias and a symlink right now and it works.
     
  5. Tutorer macrumors member

    Joined:
    Jun 9, 2011
    #5
    I just tested this and so far it works as expected here.
     
  6. brendo234 macrumors newbie

    Joined:
    Feb 7, 2008
    #6
    How are you guys going about creating sym links? I'm using the following:

    ln -s /Volumes/Data/Videos /Movies

    It always gets created as an alias. Am I just doing something wrong?
     
  7. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #7
    Look at the man page to find out all you ever wanted to know by typing the following command into terminal...

    Code:
    man ln
     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    Mac OS behavior here is confusing, and it doesn't seem to have changed in 10.7 from 10.6. A symbolic link appears to be an alias in Finder. What do you see when you look at the directory in Terminal?
     

Share This Page