All 3rd party apps are crashing on startup of the app even after a restore

Discussion in 'iPhone' started by alm99, Jul 29, 2009.

  1. alm99 macrumors 6502

    Joined:
    Oct 30, 2008
    #1
    My iPhone was working perfectly fine yesterday before I updated the weather.com application over wifi, ever since then none of 4 pages of my 3rd party apps will open on the iphone. The standard apple apps i.e. weather, email, calculator, etc. all open fine.

    I have done a reset, a hard reset and a full restore from a backup and still it is not working properly. Any ideas on what to do from here besides visit the genius bar? If I do need to go to the genius bar and they swap it out, is it a new phone or refurbed given its barely a month old.


    EDIT: Full restore without using the latest backup fixed the issue. Lost all my settings and application info, but the phone works and now needs to be setup again.
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
    I remember reading here someone else with the same issue. That person then proceeded to download a new app (get a free one) from the App Store and all was well again. Worth a try.
     
  3. colmaclean macrumors 68000

    colmaclean

    Joined:
    Jan 6, 2004
    Location:
    Berlin
    #3
    This happens to me occasionally. The way to fix it is to remove one app which has the problem from your iPhone (hold down the app icon until it wobbles and press the x). Then re-download the app using the iPhone AppStore.

    All should be fine again, until the next time!
     
  4. alm99 thread starter macrumors 6502

    Joined:
    Oct 30, 2008
    #4
    Thanks, I tried that. It didn't work. Also tried the free app solution that dZp suggested, no luck.

    I just went through a restored and didn't use my backup. The phone is empty and is working now with the applications. I am now syncing all my music, apps, etc. I will update once that is done on if it works or not.
     
  5. colmaclean macrumors 68000

    colmaclean

    Joined:
    Jan 6, 2004
    Location:
    Berlin
    #5
    Pretty lame you had to go to all that trouble!

    Someone told me that they heard from Apple Support that if you have over five pages of apps, some funky stuff can happen under 3.0.

    Hopefully if true, this gets sorted in the not-so-imminent update.
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Wow, I've been lucky I guess because this is the first I've heard of this problem, Of course I don't d/l a lot of apps
     
  7. alm99 thread starter macrumors 6502

    Joined:
    Oct 30, 2008
    #7
    Full restore without using the latest backup fixed the issue. Lost all my settings and application info, but the phone works and now needs to be setup again.
     

Share This Page