All my movie clips now have .jpg extensions: HELP!!

Discussion in 'macOS' started by Hello.there, Mar 27, 2008.

  1. Hello.there macrumors 6502a

    Hello.there

    Joined:
    Oct 12, 2007
    Location:
    Couch
    #1
    Could a kind soul out there tell me why, when I looked in Finder today, all my little movie clips (ie the usual rubbish filmed on a cheap camera) had .jpg extensions? :confused: So, when I click them they open up as pictures (ie as one frame from the video), but no longer play as videos.

    What on earth have I done? :eek:

    Thanks.
     
  2. brn2ski00 macrumors 68020

    brn2ski00

    Joined:
    Aug 16, 2007
    #2
    Just change them to .avi -- the typical Digital Camera format.
     
  3. Hello.there thread starter macrumors 6502a

    Hello.there

    Joined:
    Oct 12, 2007
    Location:
    Couch
    #3
    Okay, but there are 100s of them - do I have to go through them one by one? And have you any idea what daft thing I did to make this happen?

    Thanks.
     
  4. Blubbert macrumors 6502

    Joined:
    Nov 1, 2006
    #4
    To make it easier for you to change the extensions of all your movies, just download Name Mangler. It has an option within that allows you to easily change extensions on any number of files, and it does batch processing.
     
  5. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #5
    I highly doubt that's what happened. If they changed to JPGs, they wouldn't open like they were pictures if they were actually movie files. Preview would complain that they weren't actually JPGs (basically say they were corrupt). Are you sure you're looking at the proper files and not some thumbnails generated from the first frame or something?
     
  6. Hello.there thread starter macrumors 6502a

    Hello.there

    Joined:
    Oct 12, 2007
    Location:
    Couch
    #6
    :eek: :eek: :eek: :eek: :eek: :eek:

    Yes, I was looking at thumbnails.

    :eek: :eek: :eek: :eek: :eek: :eek:

    Thank you.

    :eek: :eek: :eek: :eek: :eek: :eek:
     

Share This Page