Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

'Allow Bluetooth Devices to Wake This Computer' never lets my Macbook Pro Sleep

jagooch

macrumors 6502a
Original poster
Jul 17, 2009
573
154
Denver, co
My 2019 Macbook 16" running macOS 10.15.7 is perpetually in clamshell mode with bluetooth logic keyboard and mouse paired with it. If I enable "allow bluetooth devices to wake this computer" in System Preferences->Bluetooth->Advanced settings , my MacBook wakes up every few minutes. If I uncheck the setting, the behavior stops. But then I have remove the Macbook Pro from the clamshell dock I have it in, open it, and then close and put it back to wake the computer. I'm looking to avoid having to do this.

Btw, I'm no where near the mouse and keyboard when it happens, so I'm assuming another device is waking it up via bluetooth. I think Apple docs state that the device has to be paired with the Mac in order to wake it up.


I've unpaired all bluetooth devices except for ones that I frequently use with the Macbook
1. Logitech keyboard
2. Logitech mouse
3. AirPods

Looking at what is paired , I guess the AirPods are the culprit.

I'd like to be able to wake the computer with the keyboard and mouse, but just by using the keyboard and mouse.

Are there any hidden settings , utilities, or other ways that I can achieve this?
 

Taz Mangus

macrumors 603
Mar 10, 2011
5,091
1,259
Have you tried different combinations of your BT devices:
  • Only keyboard paired.
  • Only mouse paired.
  • Only AirPods paired. I would think you could wake the computer with the AirPods.
To try this out set the time for the computer to sleep to 1 minute. You will probably also need a wired keyboard for this testing. Also, try doing a SMC reset.

 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.