Amazing 3G speed then stick permanently to very low speed

Discussion in 'iPhone' started by vanillablue, Sep 17, 2008.

  1. vanillablue macrumors newbie

    Joined:
    Sep 13, 2008
    #1
    I've noticed a strange problem with my iPhone 3G restored completely 3 times with 2.1 and configured as a new phone.

    I'm able to reach speed of 1800 kbps and average 1300 kbps but, as soon as my phone has to switch from or to GPRS in areas without 3G, from there the max speed allowed with 3G (when available) is 200 kbps, everywhere, also in different cities with full 3G signal.

    The only solution that I found, but extremely temporary, is either to switch off and on 3G or Airplane Mode but as soon as my connection type change the problem reoccurs.

    Has someone experimented the same problem as mine testing the same? ...or found a solution?

    Thank you
     
  2. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    I don't know how you are even getting 1800 Kbps I get consistently around 600 Kbps on 3G. That's pretty impressive that you can get speeds like that. I guess maybe my area just isn't as good as where you are. All that to say, the speeds I get are pretty consistent at home but when I travel I get some variation but not to the extent that you are.
     
  3. vanillablue thread starter macrumors newbie

    Joined:
    Sep 13, 2008
    #3

Share This Page