An interesting problem relating to SIM Pin funness (or not)

Discussion in 'iPhone' started by jackgbanks, Apr 15, 2013.

  1. jackgbanks macrumors newbie

    Joined:
    Apr 26, 2011
    #1
    Bit of an odd one here, and it might take a little while to explain, so please stick with it and don't go and enjoy a cool mojito on your balcony.

    I've got an iPhone 5 16GB, unlocked but originally bought in the UK. I had an Orange sim card in it until I moved to Norway for six months. When I arrived I bought a pay as you go sim from Chess (Subsidiary or NetCom), which was cut down to nano-sim size by the nice people in the NetCom shop. I had to enter a pin code to unlock the sim which was all fine and dandy. Said nano-sim was subsequently topped up and used successfully used for a couple of months.

    After a while I had to turn off my phone for whatever reason and when I turned it back on, it asked for the pin code. This was no problemo and once I entered it, it was fine.

    Now it gets interesting. I happened to turn off my phone again (battery saving on a trip to the fjords, no less), but when I turned it back on to enter the pin, it froze. Well, kinda froze; it simply said 'sim unlocking...' and hung like that for ages. I turned my phone on and off a couple of times and entering the code worked.

    I thought no more about it until I turned my phone off again. Big mistake. Now I can't get the bloody thing to unlock. Whenever I turn the phone on and off and enter the code, it just hangs with 'sim unlocking...'. IT DOES NOTHING. I've tried resetting, hard resets, factory restored (restarted using UK sim card [obviously I don't want to use this and has in actual fact been suspended whilst I'm away]) and yet nothing seems to work. The funny thing is that when I enter an incorrect pin, it comes up saying 'incorrect pin' and knocks it down to 2 attempts remaining. It doesn't do this when I enter the correct pin, so it clearly recognises it as the right code, it just refuses to unlock.

    I've tried searching the interwebs for something that can help me but there is bugger all that I can find.

    So if anyone's got any idea of what I can do that'd be great. It's not the end of the world, but is bloody irritating.

    THANKS BABES
     
  2. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #2
    Have you tried a different sim to see if it's phone or the sim itself that's a problem?
     
  3. jackgbanks thread starter macrumors newbie

    Joined:
    Apr 26, 2011
    #3
    I have tried another sim, but not one that had a pin lock on the sim, and it worked fine. Whether or not this is a bug with the iPhone itself when it comes to unlocking the Sim, or with the sim itself remains to be seen.
     
  4. ParagJain macrumors 6502

    Joined:
    Jul 24, 2011
    #4
    what if, when you have entered the correct sim, you eject the sim..does the phone respond ? it should goto home screen and give a message no sim inserted...

    or did you try to start your phone without sim and then insert the sim once you are at home screen ??
     
  5. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    Sounds like the cut down sim isn't making proper contact....Maybe you could go back to the store? They can also get dirty when they've been cut. I've actually washed sims that refused to work and got them back. Warm soapy water and a soft sponge...( DON'T immerse ) and wipe gently. Dry with a micro fibre cloth completely and try it again.
     
  6. jackgbanks thread starter macrumors newbie

    Joined:
    Apr 26, 2011
    #6
    Thanks for the responses guys.

    ParagJain - When I enter the correct pin and then eject it, it reverts to the home screen and says no sim card installed. Turning the phone on without the sim and then inserting it didn't work either unfortunately.

    Macman45 - Just tried cleaning it as you suggested but, alas, to no avail. Perhaps I'll try and go back to the store tomorrow and see what they say.

    Any other suggestions, however ludicrous, are more than welcome :)
     

Share This Page