Annoying - dock unhides itself in Mountain Lion when switching spaces

Discussion in 'MacBook Pro' started by inertiat, Jul 30, 2012.

  1. inertiat macrumors member

    Joined:
    May 9, 2008
    #1
    Topic does what it says on the tin. :mad:

    Mountain Lion, fresh install, dock is set to autohide. Whenever I double-click on a dock icon for a different app and that app happens to be in a different space, I get taken there as usual but the Dock decides to stay up and unhide itself. To stop it I have to right click on it and turn hiding on. This also happens if say I'm in mail fullscreen and click on a Safari link - when I get taken to Safari in a different space the dock unhides itself.

    Interestingly, in the System Prefs it says that autohide the dock is selected.

    Does anyone have any ideas or had a similar experience? So annoying because it all seemed to work perfectly (even the dashboard remembers to keep icons in their place unlike in Lion!). Are there any prefs files I can trash?

    Thanks so much
     
  2. Beanlok macrumors regular

    Beanlok

    Joined:
    Nov 28, 2008
    #2
    I auto-hide my dock. I just tried to replicate these issues to no avail. Sorry, no ideas either.
     
  3. inertiat thread starter macrumors member

    Joined:
    May 9, 2008
    #3
    Woop managed to fix it myself - here's how to do it if anyone encounters it:

    Go to User/Library/Preferences/

    Delete com.apple.dock.plist

    Make a change to the dock and it will generate a new .plist file for the dock. It should all work. :)
     
  4. ednerd macrumors newbie

    Joined:
    Jan 17, 2013
    #4
    I am having this exact problem where the dock unhides and stays unhidden when clicking on an app icon in the dock that is in another space.

    Deleting the plist doesn't fix it for me. Any ideas? Thanks.
     
  5. hswift macrumors newbie

    Joined:
    May 28, 2013
    #5
    Same Issue

    I'm having the same issue when I click on an icon to change to a program on a different space autohide gets turned off. Gr. Driving me crazy.
     
  6. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #6
    Does Cmd+tab cause the same behavior?
     
  7. tjmn macrumors newbie

    Joined:
    Jun 29, 2013
    #7
    For me, yes, cmd+tab also causes autohide to be turned off. Deleting the .plist did not work for me either.
     

Share This Page