Anyone have Wake-On-LAN (WOL) working in 10.8? Still not working in 10.8.3.

Discussion in 'OS X Mountain Lion (10.8)' started by botsmack, Aug 21, 2012.

  1. botsmack, Aug 21, 2012
    Last edited: Mar 14, 2013

    botsmack macrumors member

    Joined:
    Dec 16, 2008
    Location:
    Birmingham, AL, USA
    #1
    I had Wake-On-LAN working in Lion, but since I upgraded (via a fresh install) to 10.8 I can't get WOL working using the "fixes" I used in 10.7. There is a 4-page thread over in the Lion forum, which is what I used to get this working on Lion. So far nothing works (for me) in Mountain Lion. Is there a new setting I need to check?

    I'm running the same computer "Early 2011" MacBook Pro.

    Edited /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
            <key>Kernel Flags</key>
            <string>darkwake=0</string>
    </dict>
    </plist>
    Also updated /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    Changed "PrioritizeNetworkReachabilityOverSleep" to "1".

    Computer still won't wake.
     
  2. indefinitedrums, Aug 21, 2012
    Last edited: Aug 21, 2012

    indefinitedrums macrumors newbie

    Joined:
    Jul 18, 2012
    #2
    OK, I know what you're thinking(I had exact same thought), but PrioritizeNetworkReachabilityOverSleep literally prioritizes being connected to the network OVER its priority to sleep, so all it does it prevent your mac from properly sleeping(so prob best to set back to default)... now I too under lion had disabled dark wake, but in ML I have taken out that kernel flag... I have not had the same issues logging into my mac under ML, although sometimes it "just (doesnt) work"... What are you using to login? SSH? This is what I would do to start....

    Ensure "wake for ethernet access is enabled in sys pref

    Change both darkwake and PrioritizeNetworkReachabilityOverSleep back to their default values, Reboot

    For good measure, reset SMC and PRAM

    Go into System Preferences>Sharing and uncheck remote login AND screensharing, then recheck them(this will kickstart the services)

    Put the computer to sleep manually, and wait about 2-3mins, then try to wake it, idk about other services, but ssh surely wakes a WOL mac, I would start with this.

    Another thing, are you trying to access over the internet or in your LAN? Obviously, if over WAN, youll have to open and forward ports on the router. Let me know if it helps or not so we can look into this further.

    Beau

    NOTE: I am using a retina macbook, so possibly PowerNap+Darkwake has made WOL more reliable(you can even ssh into a PowerNapped[closed] macbook!)
     
  3. botsmack, Aug 22, 2012
    Last edited: Aug 22, 2012

    botsmack thread starter macrumors member

    Joined:
    Dec 16, 2008
    Location:
    Birmingham, AL, USA
    #3
    Thanks for your post and clarification regarding "PrioritizeNetworkReachabilityOverSleep". To be honest I only tried that for Mountain Lion. I never had to enable that for Lion — darkwake seemed to be all I needed.

    I undid the plist changes and reset the SMC and PRAM like you suggested. If I send a magic packet the same way as before it doesn't appear to work. Here's the odd thing. If the MacBook Pro is asleep and on the network, I can't ping it. However after I send it a magic packet to wake it up, the screen stays black, but I can start pinging it.

    Other notes... I don't have Screen Sharing or Remote Login enabled in Sharing. Do I need them for this? I can't recall how they were configured before installing Mountain Lion. It's very possible they were enabled, but it was my understanding that Wake-On-LAN didn't require anything more than checking that "Wake for network access" is enabled, which it always has been.

    This is strictly over wired ethernet. Same LAN, IP address range, domain, etc.

    A little background if you want... I have a Windows 7 PC at the office as my main work computer. I have my MBP (lid closed) in a vertical stand connected to an external monitor. I then connect to the MBP via Synergy (client). My whole process was:
    1. Hook up the MBP
    2. Wake it from the Windows PC
    3. Then have my launch daemon run my custom bash script that connects to SSH and Synergy on the PC
    All of that worked.

    [Edited to add]
    I did enable Remote Login and put it to sleep. From Windows, using Putty, I was able to SSH into the MBP and access it, but the screen stayed black. So maybe it is technically waking, but it's not fully waking up. If I have an external mouse hooked up during this whole process, even if I move the mouse the screen stays black. It's only after I press a mouse button does it full wake. Odd.

    Not sure if this matters, but this showed up in the logs around the time the SSH session activated, but the display stayed black:

    Code:
    8/22/12 12:22:06.550 PM WindowServer[86]: handle_will_sleep_auth_and_shield_windows: no lock state data
    [More Edits]
    I did a fresh reboot and immediate sleep after the reboot. I then attempted to wake it. After it still shows a black display, I "fully woke" it with a USB mouse. This is what the console reported for this time. My public IP address is edited out. I highlighted in red below the questionable log entry.

    Code:
    8/22/12 1:37:53.000 PM kernel[0]: AirPort_Brcm43xx::powerChange: System Sleep 
    8/22/12 1:37:57.000 PM kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link down on en0 (wol enabled, BJP 3040)
    8/22/12 1:38:00.000 PM kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link up on en0, 100-Megabit, Full-duplex, No flow-control, Debug
    8/22/12 1:38:26.000 PM kernel[0]: Wake reason: GIGE (Network)
    8/22/12 1:38:26.000 PM kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
    8/22/12 1:38:26.000 PM kernel[0]: AirPort_Brcm43xx::checkInterfacePowerState: Check _pwrOffThreadCall!
    8/22/12 1:38:26.000 PM kernel[0]: Previous Sleep Cause: 5
    8/22/12 1:38:26.000 PM kernel[0]: TBT W (1): 0 [x]
    8/22/12 1:38:26.383 PM configd[17]: network changed: v4(en0-:<IP Removed>) DNS- Proxy- SMB
    8/22/12 1:38:27.000 PM kernel[0]: AppleBCM5701::selectMedium - autoselect, any duplex, EEE allowed, flow control allowed
    8/22/12 1:38:28.000 PM kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link down on en0
    8/22/12 1:38:28.000 PM kernel[0]: Ethernet [AppleBCM5701Ethernet]: Wake reason GIGE - magic packet received
    [COLOR="Red"]8/22/12 1:38:29.000 PM kernel[0]: Graphics suppressed 2912 ms[/COLOR]
    8/22/12 1:38:30.000 PM kernel[0]: Ethernet [AppleBCM5701Ethernet]: Link up on en0, 100-Megabit, Full-duplex, No flow-control, Debug
    8/22/12 1:38:31.851 PM configd[17]: network changed: v4(en0+:<IP Removed>) DNS+ Proxy+ SMB
    8/22/12 1:38:41.084 PM WindowServer[83]: handle_will_sleep_auth_and_shield_windows: no action for lock state 1
    8/22/12 1:38:41.000 PM kernel[0]: HID tickle 14964 ms
     
  4. botsmack thread starter macrumors member

    Joined:
    Dec 16, 2008
    Location:
    Birmingham, AL, USA
    #4
    Just to update, but 10.8.1 didn't fix anything with regards to this issue.
     
  5. indefinitedrums, Aug 24, 2012
    Last edited: Aug 24, 2012

    indefinitedrums macrumors newbie

    Joined:
    Jul 18, 2012
    #5
    OK, thanks for following up, I will connect my(rmbp) and another macbook(2010 c2d mbp) to ext display in clamshell mode to test this weekend. Are you using a time capsule/aebs/aexp? I know macs on an apple router use a bonjour proxy for "wake-on-demand" which has been much much more reliable for me than using another router(see: https://support.apple.com/kb/HT3774). Seems it sets up a 'proxy' hosting your services as if the PC were active on the network, so when you attempt to use the service, it contacts the PC and wakes it.
    I hate suggesting this but I'm pretty sure people with similar issues(like a headless mac mini) use something like logmein, which doesn't need(afaik) the actual screen to display something like screensharing/vnc does, just something to try.
    Another thing is, I do not use any kind of magic packet anymore, just ssh, and it fully wakes it... this also may have to do with the sleep proxy, something I'll have to test with an old router as well. Ugh! When will apple give us proper remote access! With windows, you can have headless sessions, and/or have it just lock the screen... or even concurrent login remote sessions! Don't get me started on "real" WOL, which should be able to boot from cold state(off), not just wake a sleeping PC. And RDP, which is sooo fast and beautiful with even minimal bandwidth... sigh(if you are interested in rdp server from mac, iRapp is fantastic, but still not quite a windows experience).
    After you ssh, you say the display is black, are you ref'ing to synergy, or just the physical display, if synergy, have you tried tapping a few keystrokes/mouseclicks(remotely), immediately logout, and then back in?
     
  6. botsmack thread starter macrumors member

    Joined:
    Dec 16, 2008
    Location:
    Birmingham, AL, USA
    #6
    Thought I would keep this updated. 10.8.2 never fixed this either. Bug submitted to Apple. Hopefully, they will be able to take a closer look.
     
  7. meme1255 macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #7
    Anyony who has working WoL? Mine Mac wakes in "darkwake" state, if at it wakes at all ( its 10:1 (doesn't wake / does wake) :(
     
  8. palebluedot macrumors 6502a

    palebluedot

    Joined:
    Jun 29, 2008
    #8
    I was able to connect to my MBA (in clamshell with no external) briefly via VNC. It showed me the password screen. When I log in VNC crashes (I assume the Mac goes back to sleep).

    This only works if I open the mac, let it connect to wifi, then close it and let it go to sleep. If I wait a minute or two after that (or just plug in my Air from my backpack after it being away from my wifi networking) it doesn't work.

    Windows has been able to do this for years, come on Apple!
     
  9. LeeBradley100 macrumors newbie

    Joined:
    Nov 15, 2012
    #9
    Darkwake in Mountain Lion

    Been struggling with this problem for some time. It seems that editing the com.apple.Boot.plist file is the solution. Many thanks!!
     
  10. botsmack thread starter macrumors member

    Joined:
    Dec 16, 2008
    Location:
    Birmingham, AL, USA
  11. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #11
    I got a Mac mini about 3 weeks ago as a media centre and use WOL to wake it at home and also from work. This is through my home Belkin router and it wakes fine every time. I wake it to use LogMeIn to remotely access it.
    If it is waking for you but the the screen is blank, is this on the machine you are using to access it or on the display physically connected to the Mac you are trying I wake? If it is the latter then I would presume this is by design for security reasons? Excuse me if I have picked this up wrong.
     
  12. MacDS macrumors newbie

    Joined:
    Mar 23, 2013
    #12
    Found a work around

    I installed Mobile Mouse Server on my iMac.
    Then installed Mobile Mouse apps on my iPhone 5 and iPad 2.
    Keep the MM server running.
    Now, even when my Mac is in deep sleep, and the home shared libraries are not working on my devices, I can connect with Mobile Mouse apps. Then I can go back to the home shared libraries.
    Works well with the devices but my ATV still won't connect without using the MM apps to wake Mac first.

    Extra step but it works for me until they fix it.
     
  13. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #13
    It seems to have started WOL working for me again with a late 2012 Mini, most of the time, at least.
     
  14. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #14
    I have 10.8.4 but wireless wake on lan is not working. It used to work in the good old SL days.
     
  15. jangozo, Jul 23, 2013
    Last edited: Oct 31, 2013

    jangozo macrumors member

    Joined:
    Oct 10, 2012
    #15
    I haven't got it working.

    Here are some tips from me:
    Just to clarify to everybody that when testing WOL, your mac should be connected to a power supply.

    have nothing set in com.apple.Boot.plist
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>Kernel Flags</key>
    	<string></string>
    </dict>
    </plist>
    My WOL packet gets sent from my router via port 9 to destination 192.168.1.255 (whole subnet because sending it to 192.168.1.101 (my ip) didn't work).

    WOL packet wakes up my mac for 30 seconds only before it goes back to sleep. This is my window when I have to make the initial connection from an app (ssh, VNC, etc) and stop it from falling asleep.

    You should also know that a mac can be awake even when the screen isn't on (darkwake). I used ping -t 192.168.1.101 (mac ip) for debugging on another machine on the LAN because it constantly gives you current state of the machine.

    Also one final thing I did (not sure if relevant) is that I went to Network -> Clicked Wi-Fi -> Advanced. Then I dragged my home WiFi to the top of the Preferred Networks list.
     
  16. lexvo, Jul 24, 2013
    Last edited: Jul 24, 2013
  17. braindeath macrumors newbie

    Joined:
    Mar 17, 2014
    #17
    i have the exact same problem mac mini is in sleep. i wake it up remotely over lan/wan, which works! and after 1 minute or so it goes back to sleep.

    very frustrating since i would like to have my mac mini sleep mostly of the time and wake it up only if needed.

    is there any fix for this?
     
  18. jangozo macrumors member

    Joined:
    Oct 10, 2012
    #18
    Waking up for a minute once the magic (wake up) packet is received is part of the WOL functionality. Once the system is awake if no request is made, the system will go back to sleep, this is by design.

    To update on the whole WOL thread:
    I opened a bug to apple for this issue and after months of investigation and requests the root case was that my router didn't support Apple Bonjour. It's a D-Link 615. I guess WOL on Apple is different from WOL on Windows. Well played Apple, well played.
     
  19. braindeath macrumors newbie

    Joined:
    Mar 17, 2014
    #19
    thanks for your reply!

    hmm, i did not know that. i though, wake-on-lan wakes the system completely up, until it is manually sent back to sleep.

    the problem: it even goes back to sleep if i DO requests to the mac mini. i have the plex media server running. so i wake it up remotely and start the plex app on my iphone. it detects that the server is up and running and i can stream to my iphone. after 1 minute the mac mini, however, goes back to sleep as mentioned before, the stream stops and the app does not find the media server, since it is in sleep mode.

    that sucks. how can i keep the mac awake after the wake-on-lan package was sent? obviously the plex media server does not do that after a connection was detected :( any hint?

    thanks in advance!
     
  20. jangozo macrumors member

    Joined:
    Oct 10, 2012
    #20
    That's one of the issues I had with plex also. Apple doesn't recognize it as a service which is able to keep it awake. The mini wakes up and expects connections like SSH or Remote Management (and possibly Bonjour services) to put it into real awake mode. Plex just isn't one of them. Maybe they added an option for mac installations to keep it awake, check with their support.

    I wrote a shell script which uses software called sleepwatcher and checks whether I'm streaming before it decides to go to sleep because it's been idle for too long. In this case I'm not sure the "going to sleep" check is the same as the WOL check so it may not work. In either case, check with Plex support.
     
  21. braindeath macrumors newbie

    Joined:
    Mar 17, 2014
    #21
    thanks again!

    ok, i will do that. if i hear anything from the plex team regarding this issue i will keep this thread updated.
     

Share This Page