Anyone having trouble with the video cards in the new iMacs?

Discussion in 'Mac and PC Games' started by lisamcdee, Aug 25, 2007.

  1. lisamcdee macrumors newbie

    Joined:
    Aug 25, 2007
    #1
    We bought a new black border iMac (2 GHz processor, 2 MB ram, Radeon 2400 HD video card) which arrived yesterday. The only game my family plays is The Sims 2. For the first few minutes the game played perfectly, but then objects began flashing in and out of the screen, blank squares started appearing all over and in short order the game became unplayable. We restarted and tried again but things only became worse.

    We took out all custom content and reinstalled all our Sims expansion packs from the top with no difference in game play.

    I contacted Applecare today wondering if there was a problem with the video card, but they told me that if the computer could play any video at all that the card was fine (the intro to the Sims game plays like it always does when the game is loading). Something, however, is obviously wrong.

    Is anyone else having similar problems? It is so disappointing to spend all this money for a new computer only to find out that you can't play games on it.

    Any help would be appreciated.
     
  2. justflie macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #2
    I don't know too much, but it sounds like your video card is overheating. I had this problem in a PC before; it would cause artifacting in the games (you start seeing lines or triangles instead of smooth video). There's def. something wrong in my uninformed opinion. If it's still within 14 days, I think you can exchange it for another. Maybe make an appointment with a genius if you have a local apple store nearby.
     
  3. chaosbunny macrumors 68000

    chaosbunny

    Joined:
    Mar 11, 2005
    Location:
    down to earth, far away from any clouds
    #3
    Have you run all the apple software updates? WoW also had some fancy display problems on my new iMac until I ran apple software update, which fixed it.
     
  4. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #4
    are u gaming in osx or in xp/vistas???

    i would also suggest that it could be overheating, uumm maybe get the istat widget and take a picture of the GPU temp and post it here..
     
  5. contoursvt macrumors 6502a

    Joined:
    Jul 22, 2005
  6. gamerz macrumors 6502

    gamerz

    Joined:
    Oct 2, 2006
    #6
    chaosbunny?

    What model of imac do you have, and how does WoW play on it? Do you do any raiding, PvP, basically the only graphically intesne stuff in WoW.

    Sorry to kind of intrude on this thread.
     
  7. lisamcdee thread starter macrumors newbie

    Joined:
    Aug 25, 2007
    #7
    Well, I have a sad answer to my own question.

    Apparently, the Sims 2 will not play on the new 20 inch, 2MHz iMacs. Aspyr (the manufacturer of the game) is unsure if they will be able to patch the problem or not.

    It is still a lovely computer, but if we had known about this problem in advance we would not have bought it.

    Thanks for your suggestions.
     
  8. ezekielrage_99 macrumors 68040

    ezekielrage_99

    Joined:
    Oct 12, 2005
    #8
    Or bad graphics card memory.
     
  9. djinn macrumors 68000

    djinn

    Joined:
    Oct 4, 2003
    #9
    Where can I get that widget?
     
  10. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #10

Share This Page