Anyway to point to a directory where it contains the header/library files

Discussion in 'macOS' started by just.srad, Jun 10, 2009.

  1. just.srad macrumors newbie

    Joined:
    Jun 10, 2009
    #1
    Hi, I am trying to compile the darwin ports, it prompts an error of missing md5.h. i search for it and it resides in /usr/include/sys. So i copy it to /usr/include.

    After which, the compiler complains of a missing fetch.h. This time, fetch.h is located in another directory, and i need to copy it to /usr/include.

    Then i try to compile it again, this time round, it complains of another missing header file.

    So i am wondering is there a way, to link the compiler to all the header files?
    Or did i miss out something , like a step to be done before i can compile the darwin pkg successfully without any error ?

    Thanks in advance and much appreciate for any kind of assistance.

    Jus
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    I don't think I had to compile darwin ports when I installed it. Anyways, there could have been steps for setting up the path variable so that it looks in extra locations.
     
  3. just.srad thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #3
    Thanks for the link...

    Mine is Mac X 10.4 ... that download file is meant for 10.5.
    anyway, i did try to download and install it but it cannot be run.

    Jus
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4
    What are you wanting to be able to do with Darwin Ports? There might be an alternative like MacPorts or Darwine, or Fink.
     
  5. just.srad thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #5
    Manage to install Macport.. from http://guide.macports.org. With the instruction given i am able to use it..

    Not sure from there i can find minicom... trying now.
     
  6. mslide macrumors 6502a

    Joined:
    Sep 17, 2007
    #6
    Open up terminal and type:

    $ sudo port install minicom
     

Share This Page