App is greyed out and says waiting and can't be deleted in ipod touch

Discussion in 'iPod touch' started by rugox, Oct 27, 2008.

  1. rugox macrumors regular

    Oct 16, 2008

    I don't know what has happened but after an occasion of updating my ipod touch, some applications logo in the ipod touch became greyed out and says "waiting.." in the title. It can't be tapped, deleted, or ran in the ipod touch and doesn't have anything related in the itunes as well. As you can see in the photo its just a block of grey now but it used to have the greyed out logo of the app before. When I as an experiment deleted the associated app, it became a greyout block. Does anyone else haev this problem?

  2. ltldrummerboy macrumors 68000


    Oct 15, 2007
    Have you tried restarting it? Hold down the top button. Just from the greyed-out icons, it looks like you tried installing some apps and then your Wi-Fi disconnected.
  3. pwn247 macrumors 6502


    Aug 30, 2008
    West Virginia, USA
    That happens to me when my iPod disconnects from the WiFi, or I'm getting very, very slow wireless from where I'm at. Connecting to your computer (thus into iTunes) will usually solve this- or you could always just sit outside of a McDonalds and steal their WiFi. (lol)
  4. rugox thread starter macrumors regular

    Oct 16, 2008
    Stole neighbor's wireless to connect and they disappeared. thanks for the fix.

Share This Page