App Store changed to Chinese on iOS 11 and I can’t change back!?

Discussion in 'iOS 11' started by betaboy78, Jun 22, 2017.

  1. betaboy78 macrumors regular

    betaboy78

    Joined:
    Oct 5, 2006
    #1
    iOS 11 has been working fine in my testing, but now on my iPad Pro 10.5, the App Store just randomly changed to Chinese and I can’t get it back to English. Anyone else having this issue? My other devices on iOS 11 the store is just fine. Also, the iPad WAS on the right store before. I can’t figure out this has happened. So weird!
     
  2. lsutigerfan1976, Jun 22, 2017
    Last edited: Jun 22, 2017

    lsutigerfan1976 macrumors 68000

    Joined:
    Sep 14, 2012
    #2
    That happens in beta 2? I know that was an issue in beta 1. The only thing that fixed it for me was a complete restore from scratch.
     
  3. betaboy78 thread starter macrumors regular

    betaboy78

    Joined:
    Oct 5, 2006
  4. ssieg macrumors newbie

    ssieg

    Joined:
    Sep 26, 2016
    #4
    I saw this behavior with iOS 11 beta 1 on my iPhone but not on my iPad Pro w/iOS beta 1. The fix for me was to sign out of my Apple ID. I went under settings\iTunes & App Stores... Fixed it about 2 days ago
     
  5. cswifx Suspended

    cswifx

    Joined:
    Dec 15, 2016
    #5
    It's an issue with the App Store, for some reason Apple hasn't implemented the region changing feature yet. The feature appeared in previous versions of iOS when you attempted to access an app from another store, but now it just says 'Cannot Connect to App Store'.
     
  6. mariusignorello macrumors 65816

    Joined:
    Jun 9, 2013
    #6
    The return of the Chinese translators!! But sadly not in the Keynote.
     

Share This Page