App stuck way too frequently on iOS11

Discussion in 'iOS 11' started by EvanEiga, Oct 4, 2017.

  1. EvanEiga macrumors regular

    Joined:
    Jun 15, 2015
    #1
    Is it just me or do apps often stuck upon launch in iOS 11? (FWIW I am on iPhone 7 Plus)

    When I click on an app, especially the ones that I haven't opened recently, it would get stuck on the load screen and crash out after a while. When I double click the home button, it would then appear in the mission control interface. tapping it would go to the crashing load screen again.

    A quick workaround for this that I've been using is to manually closing all the apps. (which seems crazy since apple claims that does no good whatsoever?)

    Anybody else experiencing the same issue? I've been using public betas and am on 11.1 ATM, but 11 public release was the same to me as well.
     
  2. Sharkoneau macrumors 6502a

    Sharkoneau

    Joined:
    Jan 13, 2017
    Location:
    Michigan
    #2
    You might want to try clearing out the device's RAM. Do this by holding down the power button (until you're prompted by the slider). Then, hold the home button until you're kicked back to the home screen.

    Also, have these troublesome apps been updated with iOS 11 compatibility? That could also be an issue - developers seem to be a little slow this time around. If all else fails, you may want to delete the app(s) and re-download them, which sucks; however, it could fix those issues.
     
  3. fatalogic macrumors regular

    fatalogic

    Joined:
    Aug 16, 2016
    #3
    Delete and reinstall is the only fix that works for me. I've had to do this for about 7 apps so far.... extremely frustrating.
     
  4. GeoffM1968, Oct 4, 2017
    Last edited: Oct 4, 2017

    GeoffM1968 macrumors newbie

    Joined:
    May 16, 2005
    Location:
    Tampa
    #4
    I keep having same issue and even have apps freezing. Everything from Mail, iMessage, to the phone app either slow to launch and stop responding and freezes. I have had nothing but issues with this since updating to 11.0 and 11.01. Attached image is when the phone app froze. I had to restart my phone to fix.

    Another issue is with tones and ringtones. What I had set up before updating to 11 and 11.01 stopped working. I have individual tones and ringtones for individuals and custom defaults. I can go in and see them still with the tones and ringtones set up but they won’t work. Not sure why or how to fix as nothing I have tried has worked.

    It is very frustrating to say the least. Geoff
     

    Attached Files:

  5. Broadwayltd1 macrumors newbie

    Broadwayltd1

    Joined:
    Aug 31, 2017
    Location:
    PA
    #5
    --- Post Merged, Oct 7, 2017 ---
    you are so not alone. but until apple fixes the iPhone 8 issues, the iOS 11 for iPhone 8 and gets the iPhone X launched i don't believe apple will take care of the 7/7+ issues. they're priorities are the stock holders first not to those that have already purchased the ~$800 iphone7/+ brick.
     

Share This Page

4 October 4, 2017