Apple forced me to update to iPhoto 9.1, now wont work at all...

Discussion in 'Mac Apps and Mac App Store' started by freeny, Nov 22, 2010.

  1. freeny macrumors 68020

    freeny

    Joined:
    Sep 27, 2005
    Location:
    Location: Location:
    #1
    iPhoto wouldnt open unless I updated to 9.1. now my computer says iPhoto is open but nothing showing, no interface, no little glow spot under the icon...
    Ive restarted several times and same issue...

    running OS 10.6.5
     
  2. BaldiMac macrumors 604

    BaldiMac

    Joined:
    Jan 24, 2008
    #2
    First thing that I would do would be to verify your hard drive using Disk Utility, and repair any errors. Repair permissions.

    If you had any disk problems, reinstall iPhoto from the disc. Make sure you update to 9.1 before opening the library.

    If there were no hard drive problems, that you probably have a library problem. Hold down Command and Option when start iPhoto, and you will get several options to repair your library.
     
  3. freeny thread starter macrumors 68020

    freeny

    Joined:
    Sep 27, 2005
    Location:
    Location: Location:
    #3
    I cant even get to the point of holding down opt/cmd...

    Icon just bounces for a while then stops. My force quit app says iphoto is open but the icon has no little glowing dot below it and trying to launch does nothing. ive reinstalled the app now 3 times with the same result.

    Both with updating to 9.1 and not. I actually cant even launch under 9.0 and i am told i must upgrade to 9.1 before i can launch.

    I even backed up my photos and deleted all of iphoto and tried again... same result...
    After deleting everything and reinstaliing iphoto 11 it says im still upgrading...

    This upgrade SUCKS!

    AND ive repaired permissions twice...
     
  4. BaldiMac macrumors 604

    BaldiMac

    Joined:
    Jan 24, 2008
    #4
    I'm not sure what this means. You should be holding down cmd/opt when you click on the app to launch.
     
  5. robert05au macrumors regular

    robert05au

    Joined:
    May 19, 2005
    Location:
    Dubbo, NSW
    #5
    It should be option/command and press escape to bring up force quit options on the screen.

    Could yopu by any chance post a crash report it maybe found in HD/library/Logs or Home/Library/Logs

    This may lead to a cause of the problem.

    Do you have any third party addons that work with iphoto?
     
  6. freeny thread starter macrumors 68020

    freeny

    Joined:
    Sep 27, 2005
    Location:
    Location: Location:
    #6
    I have been working with macs for over 23 years. I usually can fix these things.

    I know how to force quit

    Keep in mind I have reinstalled the app 3 times now. I even downgraded to iPhoto 09 then upgraded again.

    I had iPhoto 11 (9.0) running fine. I launched iphoto today and was met with a message "you must upgrade to 9.1 before iPhoto can start" so i did...

    Now it does not seem to be working.

    upon launch the icon bounces for about a minute then stops. clicking the icon again does nothing. when I launch force quit iPhoto is listed as a running app but it is not visible anywhere, not even in the finder. I force quit and try launching again.... same result.

    Ive repaired permissions several times
    Ive reinstalled the app several times
    Ive downgraded then upgraded several times...
    same result every time.

    When I downgrade to the previous iPhoto it does launch. But once I upgrade the same thing happens every time...

    When I hold down cmd/opt on iphoto launch nothing happens
     
  7. indy73 macrumors newbie

    Joined:
    Nov 22, 2010
    #7
    Fix

    It's easier than you'd think . Open Finder go to your HD then Library then Quicktime then delete the DiVX files .
     
  8. freeny thread starter macrumors 68020

    freeny

    Joined:
    Sep 27, 2005
    Location:
    Location: Location:
    #8
    Bingo :)
     
  9. penini macrumors newbie

    Joined:
    May 12, 2009
    #9
    TY freeny — Your iPhoto 9.1 Divx fix works!

    The culprit (in my case) was DivX Decoder.component 6.4.0, - Created 2/26/07 — found in the Mac's main Library\QuickTime folder.

    iPhoto 9.1 library rebuilt itself, and all is well, so far.

    Many thanks
     
  10. penini, Nov 27, 2010
    Last edited: Nov 27, 2010

    penini macrumors newbie

    Joined:
    May 12, 2009
    #10
    Thank You, your iPhoto 9.1 Divx Fix works!

    Big thanks to indy73 for the fix.
     
  11. extra-stout macrumors newbie

    Joined:
    Jan 11, 2011
    #11
    Any Other Ideas?

    You can imagine my disappointment when I found no divx codec in the Quicktime Folder. At least knowing that more people are experiencing the same exact problem I am is comforting. iPhoto bounces for about a minute, then nothing. When using Command+Tab, it doesn't appear with the other running applications. If I hold the trackpad button down, an option to quit appears. If I CTRL+Click, a Force Quit option appears, and an indication that iPhoto is not responding.

    I've re-installed, removed the Library, held Option while launching, held Command+Option while launching, and checked for Console Messages. The only message relating to iPhoto is me force quitting. I've also repaired disk permissions. I'm going to repair permissions again from the Mac OS Install Disk and I'll post again if this takes care of it.
     
  12. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #12
    Apparently, adding your Bootcamp partition to Privacy in Spotlight may correct the problem; it did for me.

    Got that from an Apple support forum

    System Preferences > Spotlight > Privacy then either click the '+' sign and add your Bootcamp partition, or, if your Bootcamp Partition is visible on your desktop, just drag it into the Privacy section.

    iPhoto (iLife '11) wouldn't open on my MBP, running 10.6.6, starting yesterday afternoon. I updated to 10.6.6 weeks ago, don't know why this issue just started yesterday but this procedure corrected it.
     
  13. pjazzy macrumors newbie

    Joined:
    Aug 29, 2009
    #13
    This just happened to me. I was pulling my hair out trying everything I read in forums, even installed iLife '11 twice but no difference. Then came across this tip and it worked!

    Many Thanks!
     

Share This Page