Apple Mail 5.1: Replying to a message in my 'Sent' box, it makes me the recipient

Discussion in 'Mac OS X Lion (10.7)' started by Rab Simpson, Jan 25, 2012.

  1. Rab Simpson macrumors regular

    Rab Simpson

    Joined:
    Feb 10, 2006
    Location:
    Glasgow, Scotland
    #1
    Hi folks,

    I've always thought this was a kind of odd behaviour, and recently something changed and it started making the person I sent the message to initially the recipient of the new message, which is what I want, but now it's reverted back.

    I'm probably best breaking it down:
    • I send a message to someone -
      <rab@domain> ---> <originalrecipient@domain>
    • I realise there was something I forgot to add to the message, so I find it at the top of my 'Sent' box, select it, and hit reply and it gives me this -
      <rab@domain> ---> <rab@domain>
    • Whereas what I'd like it to do is just the same as the first message I sent (which it was doing for a few days at least) -
      <rab@domain> ---> <originalrecipient@domain>
    Can anybody help me get it back to the way I want it? i've looked through the preferences but I can't see anything related to this behaviour.


    Cheers,
    Rab
     
  2. jasonvp macrumors 6502a

    jasonvp

    Joined:
    Jun 29, 2007
    Location:
    Northern VA
    #2
    Do a "Reply-All" and then remove your name from the To: header while editing the message. An extra step, but it should work fine.

    jas
     
  3. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #3
    Since the "Sent" message has your e-mail address as the "From", it should be completely obvious that replying to this message will have your e-mail in the "To" field.
     
  4. Rab Simpson thread starter macrumors regular

    Rab Simpson

    Joined:
    Feb 10, 2006
    Location:
    Glasgow, Scotland
    #4
    This is what I'm used to doing, although it's not ideal.

    Of course that makes sense, but like I said recently it hasn't been the case and it's actually been working as I wanted it to, as described above. Not only that but the likes of Gmail does this (the way I like it) so while Mail was doing it recently I'm sure I'm doing something wrong here.
     

Share This Page