Apple Mail taking up a TON of room with Gmail+IMAP

Discussion in 'Mac Apps and Mac App Store' started by gordonf238, Nov 14, 2007.

  1. gordonf238 macrumors newbie

    Joined:
    Nov 14, 2007
    Location:
    NYC
    #1
    So I've finally gone ahead and configured my Apple Mail (on Leopard) with Gmail's IMAP. First, I must say I wasn't very impressed at Apple Mail's interface. It's minimalistic (which is a good thing) but lacks the aesthetic appeal, and the ability to easily browse through and view messages. At work I use Microsoft's Entourage, and I've gotta say, it's a lot easier to use (from a user-interface standpoint). Maybe it's because my messages appear in a column to the left and are twice as high, whereas Apple Mail's are only as high as one line of text.

    In any case, I've set my Apple Mail according to the directions (and tips) outlined here: http://5thirtyone.com/archives/862

    Then, yesterday I began to notice that messages in my inbox (which I've read) still showed up as unread in my Trash (which is in-effect the "All Mail" folder). So I've gone ahead and checked my user/library/mail folder, and it clocks in at 4.8GB! Strangely, when I log-in to Gmail (on the web), it only shows me as using 1.7GB of the 5GB quota.

    Is Apple Mail keeping duplicate copies of my messages in its Inbox / Sent / Trash folders? This would certainly be the case.

    Can anyone offer some explanation please? Many thanks up-front guys :)
     
  2. adrianblaine macrumors 65816

    adrianblaine

    Joined:
    Oct 12, 2006
    Location:
    Pasadena, CA
    #2
    I'm not sure what is going on with yours, but I have several email accounts set up in Mail (gmail, school, work. All IMAP) and mine is only 1.5 GB. That's roughly 4 years worth of email all together with moderate use.

    You can change the size of the mail view window to more than one line. Just drag the divider which ever way you want.
     
  3. yoavhacohen macrumors newbie

    Joined:
    Jan 31, 2008
    #3
  4. Let's Sekuhara! macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #4
    I tried using Apple Mail for my IMAP Gmail but it was a nightmare. It tried to import everything and took ages and ages. I finally gave up. It's sad because I really wanted to use Mail and Gmail together.

    I don't need to keep offline copies of messages, so I wouldn't even mind if it just loaded them up as if it were webmail. The only feature I would have really liked is the smart mailboxes. But it looks like the only way is to download them all to the local machine. Oh well.
     
  5. NeoMayhem macrumors 6502a

    Joined:
    Aug 22, 2003
    #5
    Mail.app was cool in the Tiger days, but I think gmail is better then any desktop mail client these days.

    Like posted above, the reason it uses a lot of space is because each message is duplicated in inbox, all mail and any labels you have a message in.
     
  6. OngL macrumors member

    Joined:
    Feb 17, 2009
    #6
    I had same issues and have not found the answer so far.

    Is there a way to limit IMAP message sync e.g. last 7 days or so. Like iPhone. This doesn't make sense to sync everything.
     
  7. Chase R macrumors 65816

    Chase R

    Joined:
    May 8, 2008
    Location:
    PDX
    #7
    I just use Gmail POP, not IMAP... No issues whatsoever (yes I know the advantages of IMAP).
     
  8. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #8
    hhmm my mail is only 750mb, i have had a good 5000 messages come through my account.

    wierd eh??
     
  9. OngL macrumors member

    Joined:
    Feb 17, 2009
    #9
    This creates an issue as I'm using iphone and outlook to access my mail from elsewhere. Those retrieved messages by POP won't be retrievable by other mail client.
     
  10. kamochan macrumors newbie

    Joined:
    Feb 20, 2009
    #10
    The message duplication issue is real, because of the "pseudo-folder" All Mail that Gmail keeps. It's a pain, because you cannot subscribe to selected folders only using Mail.app, like you can with most other IMAP clients.

    So, what you need to do: go to gmail, Settings, Labs, find Advanced IMAP Controls, and select Enable. Now go to Labels (under Settings), and notice that you have a check-box for "show in IMAP" for each label.

    I have disabled Starred, All Mail, and Drafts from showing via IMAP, and I am perfectly happy with Mail.app + gmail now :D
     
  11. OngL macrumors member

    Joined:
    Feb 17, 2009
    #11
    Anyone tried Microsoft Entourage? Does it works better?
     

Share This Page