Apple trailer site works under Windows but not any OS X browsers?

Discussion in 'Mac Apps and Mac App Store' started by AVR2, Aug 16, 2011.

  1. AVR2 macrumors 6502

    Joined:
    Jan 16, 2006
    #1
    I'm trying to view trailers on the Apple site, but no matter which movie I choose, the buttons that allow you to choose the size of the trailer don't appear. If I mouse around the area of the screen where the buttons should be, the pointer changes to a hand and I can see the relevant links appearing in the status bar at the bottom of the screen, but if I click anything, I just get taken back to the front page. This happens under Safari, Firefox and Chrome (all latest versions of each). I'm running OSX 10.6.8.

    Using the exact same net connection, if I use a Windows 7 box with Internet Explorer, everything works fine.

    Any ideas on how to get the site working with my Mac again? The same thing happens at work - the site doesn't work on Macs, but *does* work on Windows boxes.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
  3. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #3
    Which is great for you, I'm sure ;)

    Googling reveals that a *lot* of people are experiencing this problem and have been for months, but not even Apple appears to have a solution. Given that it's an Apple site, it's obviously somewhat annoying that it only seems to be affecting OSX and not Windows.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    I'm just saying that its working for me so it cannot be a complete platform failure. btw, I'm on 10.6.7
     
  5. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #5
    I did a bit more Googling, and several people opined that it's actually down to a piece of broken Javascript at Apple's end. They suggest that some of Apple's servers have the broken script and others don't, and which sort you end up connected to may be down to geographical location.

    I'm based in Dubai, so I tested this theory by switching on my VPN and choosing a gateway in Washington DC - the trailer buttons didn't appear. Changed the gateway to Los Angeles, and the trailer buttons *did* appear, and the site works as normal.
     
  6. jhesse macrumors newbie

    Joined:
    Apr 12, 2007
    #6
    I'm currently having the same problem with Safari 5.1.7 on 10.6.8.

    Setting Develop>User Agent to Firefox seems to get it working again.
     
  7. stewartx macrumors newbie

    Joined:
    Mar 24, 2013
    #7
    The trailers (with buttons) are working just fine with my copy of Safari as well (v6.0.3, OSX 10.8.3). Again, not much help, but further evidence the problem is not software systemic.

    While overseas, I was often not able to view various video content on American websites (YouTube, Amazon, etc). Same with some audio content (music files, etc). Much of that unviewable content was intentionally blocked in compliance with video or music industry copyright demands.
     

Share This Page