Apple TV 2 requires home sharing to be turn on and off everytime

Discussion in 'Apple TV and Home Theater' started by ccolaco, May 8, 2011.

  1. ccolaco macrumors 6502

    Joined:
    Jul 5, 2007
    #1
    I am having an issue with my Apple TV2 that I'm wondering someone can help me with.

    First few days using my Apple TV2 everything was fine, but now every time I want to access the media on my iMac, I have to go into the settings and turn off and then back on Home Sharing. It does not automatically "connect" when I turn the Apple TV on. Can anyone shed some light on this?

    I have the latest version of iTunes, as well as the latest version of iOS on the Apple TV, and both are connect via my local WiFi network.
     
  2. RWinOR macrumors 6502

    Joined:
    Sep 11, 2010
    Location:
    Greenest and wettest place in North America
    #2
    I have run into this problem more than once. The first time it happened the solution was to return my ATV2 to factory settings which grabbed an update from Apple. This was many months ago. This solution worked well.

    When the last update for ATV2 happened the problem came back. It was with both my ATV2's. I tried the return to factory settings on one unit (as a test) and it did not work. Then I downloaded the latest Safari update. Not sure how they are linked, or if it is just a coincidence, both ATV2's starting working again without the need to restart home sharing.

    My suggestion is to make sure all your software is updated, on all the source computers, and your ATV2, this has worked for me in the past.
     
  3. Cmu93 macrumors member

    Joined:
    Dec 4, 2007
    Location:
    Michigan
    #3
    I'm connected to my Windows 7 PC... but I had the same issue over and over. I uninstalled Bonjour and all Bonjour Printing options. Rebooted, reinstalled, and haven't had the issue since.

    T.
     
  4. ccolaco thread starter macrumors 6502

    Joined:
    Jul 5, 2007
    #4
    Tried a reset to factory settings and a restore/update on the TV. Problem still persists. A friend of mine just purchased one and he says the same thing is happening to him as well.

    Any other ideas?
     
  5. charks macrumors member

    Joined:
    Jul 22, 2010
    #5
    Same issues here. Homesharing would work for about 15-20 minutes...then kick out. I called Apple Care 4 separate times and went through a battery of tests...opening ports...reloading iTunes etc. Nothing helped. My case was elevated to a senior engineer...but I've yet to hear back. Really makes me think it's an Apple issue.

    In the meantime...I hardwired my Apple TV 2.
     
  6. bobdard macrumors regular

    Joined:
    Nov 10, 2008
    #6
    I've got the same problem. Tried all of the recommendations mentioned here, to no avail :(

    Hardwiring it solved your problem? Unfortunately that's not a possibility for me.

    Please let us know how your situation turns out.
     
  7. Pau.c macrumors regular

    Joined:
    Sep 20, 2009
    #7
    same here, its working one minute, next time i open up apple tv its not there it says to turn it on on my mac, but it is on, have to turn the pc on and off for it to work again!
     
  8. bbeagle macrumors 68040

    bbeagle

    Joined:
    Oct 19, 2010
    Location:
    Buffalo, NY
    #8
    The solution is to give your Apple TV and computer a static IP address - dont use DHCP.

    The issue is that when your DHCP 'lease' expires (every 24 hours), your settings are lost by Apple TV.
     
  9. ghostlyorb macrumors 6502a

    ghostlyorb

    Joined:
    Jan 9, 2010
    Location:
    Virginia, USA
    #9
    Problems like this will keep me from buying an appletv =( I really want one though
     
  10. Wavell macrumors regular

    Wavell

    Joined:
    Nov 7, 2007
    Location:
    Essex, UK
    #10
    Just adding my experience to date with this into the game..

    I'm using DHCP but with no lease expiry (also equipment gets the same IP address every time) and still getting drop outs from ATV2. Whilst I think there may be some mileage with the DHCP idea, I suspect it's not the root cause.

    Hoping Apple come out with a fix for this one sooner rather than later :(
     
  11. PaulMoore macrumors regular

    Joined:
    Dec 3, 2007
    #11
    I have an iMac- all the latest software updates installed- and an Apple TV 2.

    CONSTANTLY having this issue. (I find it quicker to quit & relaunch iTunes on the iMac as a workaround).

    Nothing to add except I'm glad it's not just me or my set-up. I also am stuck with Wifi since I can't hardwire mine.

    It really sucks and doesn't help in convincing my wife (or me, to be honest) that it's a reliable product.
     
  12. ccolaco thread starter macrumors 6502

    Joined:
    Jul 5, 2007
    #12
    Hmm, so it seems the DHCP fix does not seem to work for everybody.

    Exactly.. Except instead of wife, its parents for me. And they are the ones who make use of this product the most!

    I'm starting to think it could be in issue with our iTunes libraries?
     
  13. charks macrumors member

    Joined:
    Jul 22, 2010
    #13
    Yes...hardwiring (Cat 6 ethernet cable purchased through monoprice) completely solved the issue. Plus it gave me the excuse to buy a corded drill and masonry bits.

    Guess I'm not savvy enough to know how to assign a static IP address...but I guess it's not too involved. What's curious is that homesharing worked perfectly before the last software upgrade.
     
  14. Wildog27 macrumors member

    Joined:
    Jun 10, 2008
    #14
    I had a similar issue, using a Dual band router from Linksys. I had initially had the N band and G band set up as separate wireless networks (read somewhere that would make the wireless on the devices that use the N-band faster). Once I reset to a single network, I had to reset a setting on the router to put everything on the same bandwidth, and that solved the problem.

    At least until the the hard drive that has all our media on it became inaccessible, but that's another problem...
     
  15. ccolaco thread starter macrumors 6502

    Joined:
    Jul 5, 2007
    #15
    Apparently Apple just pushed out an update to the Apple TV2, 4.2.2. Will update and see if it has a fix for the issue we are all experiencing.

    Anyone else updated and still having the issue?
     
  16. Wavell macrumors regular

    Wavell

    Joined:
    Nov 7, 2007
    Location:
    Essex, UK
    #16
    This alone should indicate it's not DHCP but something more related with WiFi and maybe either the ATV2 or the itunes server being "woken" from sleep ..

    that's my guess, anyway.
     
  17. sonofmof macrumors member

    Joined:
    Sep 26, 2005
    Location:
    UK
    #17
    I had this problem when i was using a zyxel router on my network.

    Apperently despite enabling broadcast packets it still was not allowing the apple tv to maintain contact with my devices for more than around 30 minutes of IDLE time.

    IF i was watching content or using the apple TV box it would stay connected, but after a sleep and wake cycle it would not allow the box to find itunes.

    cycling all the devices would work as mentioned, even cycling the power on the router would also resolve the problem.

    The permenant fix was to change to linksys router and all is fine now.

    I used a great utility called browsejour to monitor when the apple tv and the itunes connectivity used to disappear depending on my location in the house and method of connecting to router.


    perhaps someone more technical than me can advise about perhaps changing the config of your router to attempt to resolve the issue ?

    Good Luck !
     
  18. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #18
    No problems here either, using a Netgear 3700
     
  19. ccolaco thread starter macrumors 6502

    Joined:
    Jul 5, 2007
    #19
    Well the recent update didn't resolve anything. Seems the majority of people here think it has something to do with the Wifi/Router settings. Can anyone add some insight on a possible solution?
     
  20. toddgarvin macrumors newbie

    Joined:
    Jan 23, 2007
    #20
    Having same issue with hardwired setup

    I have a Snow Leopard Server as my iTunes/Media Server. Everything is hooked up to an Airport Extreme router. I have 2 Apple TVs and an iPad 2. I've narrowed it down that its iTunes dropping the home share connection. Using the remote app on my iPad, i can see when the connection drops. its always iTunes/server that's dropping connection. I can still see the two apple TVs... even after the server/itunes drops off of home sharing. What makes this so frustrating is that you can't use your Apple TV without home sharing. You used to be able to stream/share directly to your Apple TV v1. This home sharing stuff is crap. When the wife and kids want to watch something, they don't understand why it doesn't work. Its driving all of us crazy!
     
  21. bobdard macrumors regular

    Joined:
    Nov 10, 2008
    #21
    Based on bbeagle's comment, I tried to setup static IP (referred to as "reserved" IP in Airport Utility) but failed - couldn't figure it out.

    But, I realized you can change the Time Capsule/Airport Extreme settings from renewing the lease every 1 day to whatever you want, so I changed it to every 100 days. So far, it's been about 20 hours, and no issues yet. Let's see what happens once the 1 day window passes.

    Anyone with a TC/AEBS, give this a shot.
     
  22. toddgarvin macrumors newbie

    Joined:
    Jan 23, 2007
    #22
    So far so good

    I changed my Airport Extreme to only update the DHCP once a year. I did that this morning at 7:00am. Its now 8pm and everything is working perfectly throughout the house. I have no idea why that would make a difference, but so far so good. I will check back in tomorrow night and let you know if its still holding onto the connection. :rolleyes:
     
  23. toddgarvin, May 17, 2011
    Last edited: May 17, 2011

    toddgarvin macrumors newbie

    Joined:
    Jan 23, 2007
    #23
    F i x e d ! ! !

    F I X E D ! ! !

    I don't quite understand why, but changing the Airport Extreme to only renew the DHCP/IP address from 1 day to 365 days, has fixed my issue of constantly losing my Home Sharing connection. Its been 24hrs since the change, and it has worked flawlessly the entire time. Before the change, it wouldn't stay connected for more than 15 minutes. Try this on your router and see if it solves the problem for you. Please report back either way.

    Thanks so much everyone for all of your hard work!!!
     
  24. damianp macrumors newbie

    Joined:
    May 17, 2011
    #24
    I've been having the same problem though I've noticed that, when ATV drops out, I am also unable to connect the Remote App on my iPhone to my iTunes library, which suggests that the problem is with iTunes rather than ATV. Has anyone else noticed the same thing?
     
  25. toddgarvin macrumors newbie

    Joined:
    Jan 23, 2007
    #25
    Yes, you are correct. I use the remote app on my iPad. When the connection is lost, i can still see both of my ATVs in the app, but I can no longer see my iTunes library.

    However, this was resolved by setting the DHCP timeout setting on my router to once every 365 days rather than once every day. I don't know why that worked, but it did.

    Give that a try and let the group know if that works for you.
     

Share This Page