Apple TV (4th Gen) Connected to WiFi but apps won't open (No connection)

Discussion in 'Apple TV and Home Theater' started by wozmatic, Jan 23, 2019.

  1. wozmatic macrumors 6502

    wozmatic

    Joined:
    Apr 30, 2014
    #1
    I have even ran the complete reset and did the software update - It says fully up to date. Any ideas on how to fix?

    ---

    It's connected to WiFi
    [​IMG]


    IP and DNS set to automatic
    [​IMG]


    Trying to open YouTube app, no luck
    [​IMG]


    Trying to open App Store, no luck
    [​IMG]


    [​IMG]

    And yes it's connected!
    [​IMG]


    I hate Apple TV :(

    Such a useless device and nothing but problems, even when it did work the airplay would always cut out. Yet every single other smart device (HUE, outlets, Nest, etc.) work perfectly fine.
     
  2. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    I had a similar experience when I tried to activate/set up my new Apple TV 4k earlier this month. The ATV was connected to my wireless network but kept saying it was not connected to the Internet. My iPhone and iPad were connected to the Internet so I know the ATV message was incorrect. I connected a ethernet cable to complete the activation and update all apps. Once completed, I removed the network cable and it's been working fine over Wi-Fi for a few weeks.

    Does it connect without encryption? Did this occur from the time you purchased the unit? Maybe take it to the Apple store for diagnosis?
     

Share This Page