Apple TV remote changing volume on my MAC even when airplay is off on tv

raghunk

macrumors newbie
Original poster
Aug 20, 2012
23
0
Hi,
I am facing this issue, not sure if any one gone thru it. When I browse apple tv using tv's remote and at the same time when I am working on my mac and also airplay is "off" on my apple tv. remote is changing volume on my Mac.
When I hit upper click on remote, it increases volume on my Mac also goes up on TV, same way it decrease volume on Mac when I click down click.
I do not like this and curious to know the fix for this one.


Thanks,
Raghu.
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
25,760
8,699
Detroit
You need to turn off the infrared remote control in System Preferences on the Mac.

Apple uses the same remote setting to run the Mac as well as the AppleTV

Choose Apple menu > System Preferences, click Security, and then click General.

Select “Disable remote control infrared receiver” to turn off IR reception, or deselect it to turn on IR reception.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
Hi,
I am facing this issue, not sure if any one gone thru it. When I browse apple tv using tv's remote and at the same time when I am working on my mac and also airplay is "off" on my apple tv. remote is changing volume on my Mac.
When I hit upper click on remote, it increases volume on my Mac also goes up on TV, same way it decrease volume on Mac when I click down click.
I do not like this and curious to know the fix for this one.


Thanks,
Raghu.
Unpair your aTV remote with you Mac: http://support.apple.com/kb/HT1555?viewlocale=en_US&locale=en_US
 

waw74

macrumors 68040
May 27, 2008
3,232
227
this won't work, you would have to pair the mac with a second remote.

if you paired the aTV, the aTV would only listen to that one remote, but the Mac would still listen to all remotes (including the one you're using for the aTV). and the same problem would exist.

if you don't have a second remote, you should just turn off the receiver in the mac as sandbox said.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
this won't work, you would have to pair the mac with a second remote.

if you paired the aTV, the aTV would only listen to that one remote, but the Mac would still listen to all remotes (including the one you're using for the aTV). and the same problem would exist.

if you don't have a second remote, you should just turn off the receiver in the mac as sandbox said.
How about this one: http://support.apple.com/kb/HT1619? I don't understand why you have to turn off the IR function vs just unpair the aTV remote from the Mac. I did that and I can use my aTV remote with my Mac and the Mac does not respond to any aTV remote functions. I do have a second remote that controls my Mac. Didn't want to lose that capability by shutting IR entirely off.
 

raghunk

macrumors newbie
Original poster
Aug 20, 2012
23
0
Thanks for quick responses. I tried to turn off as said by sandbox but I do not see that option in preferences. I have late 2011 mac pro with me and i am on mountain lion.
 

heisenberg123

macrumors 603
Oct 31, 2010
6,498
9
Hamilton, Ontario
Thanks for quick responses. I tried to turn off as said by sandbox but I do not see that option in preferences. I have late 2011 mac pro with me and i am on mountain lion.
for mountain lion on the general tab in security click the lock, put in your password and than click advanced and disable IR will be in there
 

waw74

macrumors 68040
May 27, 2008
3,232
227
if you don't have a second remote, you should just turn off the receiver in the mac as sandbox said.

I don't understand why you have to turn off the IR function vs just unpair the aTV remote from the Mac.

I do have a second remote that controls my Mac. Didn't want to lose that capability by shutting IR entirely off.
without a second remote, there is no way to unpair the receiver in the mac from the aTV remote, so you have to turn it off.
and if you don't have a second remote, you don't really need the receiver on in the first place.


Basics of apple remotes and pairing:
Each remote has a code associated with it (0-255) when you hit a button on the remote, it sends the key and the code, for example "Play-128" What pairing actually does is tell the receiver to only listen to one code. Un-pairing makes it listen to all.

there are 2 options
1. Listen to only 1 code (paired)
2. Listen to all codes (un-paired)

there is no option for "ignore a particular code".

(you could probably accomplish this with remote buddy, but i'm speaking to the default OS X remote software)

you can change the code of your remote (useful if you got 2 of the same ID) by pressing menu and the center button.
so you could pair the remote with the mac, then change it's ID, and then use the remote for the aTV, but that would give you the same result as turning off the remote.


I tried to turn off as said by sandbox but I do not see that option in preferences. I have late 2011 mac pro with me and i am on mountain lion.
if your mac doesn't have a receiver, the option isn't there.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
without a second remote, there is no way to unpair the receiver in the mac from the aTV remote, so you have to turn it off.
and if you don't have a second remote, you don't really need the receiver on in the first place.


Basics of apple remotes and pairing:
Each remote has a code associated with it (0-255) when you hit a button on the remote, it sends the key and the code, for example "Play-128" What pairing actually does is tell the receiver to only listen to one code. Un-pairing makes it listen to all.

there are 2 options
1. Listen to only 1 code (paired)
2. Listen to all codes (un-paired)

there is no option for "ignore a particular code".

(you could probably accomplish this with remote buddy, but i'm speaking to the default OS X remote software)

you can change the code of your remote (useful if you got 2 of the same ID) by pressing menu and the center button.
so you could pair the remote with the mac, then change it's ID, and then use the remote for the aTV, but that would give you the same result as turning off the remote.




if your mac doesn't have a receiver, the option isn't there.
I paired my white remote, that came with my Mac to the Mac. Now the remote that came with the aTV no longer controls the Mac and aTV only the aTV. So I guess this is why I never had to turn the IR off. I told the Mac to only listen to the "white" remote. Does that make jive with your tutorial above?
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
25,760
8,699
Detroit
Thanks for quick responses. I tried to turn off as said by sandbox but I do not see that option in preferences. I have late 2011 mac pro with me and i am on mountain lion.
Sorry about that, looks like they moved it a little in ML. You need to click the advanced button at the bottom of the Security Preferences.



 

raghunk

macrumors newbie
Original poster
Aug 20, 2012
23
0
Thanks all. I was able to disable remote receiver on my Mac. Also it make sense turning off when there is no second remote. And my Mac is free from apple tv remote now. :)