Apple Watch S4: Still able to receive imessage and calls even when on Airplane Mode

kanshu

macrumors member
Original poster
Apr 11, 2012
44
10
Hello,

I just noticed today that even when I turn on Airplane Mode on my S4 it's still able to receive calls and imessages. It says 'X Disconnected' for a few seconds and then connects to my iPhone after via Bluetooth. I've rebooted the watch several times and a hard reset but it's still doing it. I've updated to the latest WatchOS the other day. The only way I can completely disconnect it is by turning my iPhones Bluetooth, which isn't really ideal since I have other Bluetooth devices that I need.

What seems to be the issue?

Thanks!
 
  • Like
Reactions: DevinNj

kanshu

macrumors member
Original poster
Apr 11, 2012
44
10
Noticed that the Bluetooth doesn't turn off when on airplane mode. Is this a bug or what?
 

DevinNj

macrumors 65816
Apr 27, 2016
1,093
813
New Jersey
Hello,

I just noticed today that even when I turn on Airplane Mode on my S4 it's still able to receive calls and imessages. It says 'X Disconnected' for a few seconds and then connects to my iPhone after via Bluetooth. I've rebooted the watch several times and a hard reset but it's still doing it. I've updated to the latest WatchOS the other day. The only way I can completely disconnect it is by turning my iPhones Bluetooth, which isn't really ideal since I have other Bluetooth devices that I need.

What seems to be the issue?

Thanks!
Noticed that the Bluetooth doesn't turn off when on airplane mode. Is this a bug or what?
Same here with me, I noticed after putting the watch in airplane mode I can still see its battery % on my iPhone. Then I realized it still communicating and like stated above by someone else no it is not normal it should not be doing this. I did the same thing reset it repaired it to my phone and still no change. I have an open ticket with Apple for something else and I want to mention this to them when I get a callback from the tech I was working with.
 

deeddawg

macrumors G3
Jun 14, 2010
8,324
2,197
US
no it is not normal it should not be doing this.
Apple support pages say otherwise.

If you’ve turned on Bluetooth on your phone on a flight before, say to listen to music, and never turned Bluetooth off in airplane mode, it’ll stay on. Given the watch tends to inherit settings like this from the phone, it would be normal for the watch Bluetooth to remain on in airplane mode in that scenario.

If you don’t like it, go into airplane mode and turn off Bluetooth, the. Exit airplane mode. It should then turn off the next time you go into airplane mode.


228B7BFE-401C-4494-B174-A38E6F97D549.jpeg
 
Last edited:
  • Like
Reactions: kanshu

kanshu

macrumors member
Original poster
Apr 11, 2012
44
10
Apple support pages say otherwise.

If you’ve turned on Bluetooth on your phone on a flight before, say to listen to music, and never turned Bluetooth off in airplane mode, it’ll stay on. Given the watch tends to inherit settings like this from the phone, it would be normal for the watch Bluetooth to remain on in airplane mode in that scenario.

If you don’t like it, go into airplane mode and turn off Bluetooth, the. Exit airplane mode. It should then turn off the next time you go into airplane mode.


View attachment 861825
Thank you, I followed your advice; While in Airplane mode, on the watch, I turned off Bluetooth and that disconnected the watch from the phone. Then I turned off/on Airplane mode and the Bluetooth was disabled this time. This just happened after upgrading to Watch OS 6. Bluetooth settings is buried in Watch OS and do not show in Watch OS' control center unlike on iPhones and iPads. Again. Thank you.
 
Last edited:
  • Like
Reactions: deeddawg

avkam

macrumors regular
Jun 9, 2014
141
64
If you turn on Wi-Fi or Bluetooth while you're in Airplane mode, they will be on the next time you use Airplane mode, unless you turn them off while in Airplane mode.
Good info here deeddawg. Thanks. I should rtfm. :)
 
  • Like
Reactions: deeddawg