Apps won't open?! on 4s

Discussion in 'iPhone' started by joeyunn, Nov 21, 2011.

  1. joeyunn macrumors newbie

    Joined:
    Nov 20, 2011
    #1
    Everytime i run my battery all the way down and start charging my phone.. my apps won't open except the ones that came installed.

    if i try to run any other app, the screen turns black for a second and returns to the home screen..
    help???
    i tried restoring twice already.
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
    I've had this issue before with my iPhone 4, I went to the Genius bar and was told it was a corrupt OS and that I would have to restore my phone and set it up as new (not from a back-up), went home and did just that and the issue continued. I went back and they decided to swap out my phone for another, I went home and restore it from the previous back-up and the issue went away.

    The only way the issue did go away was if I deleted the App and then re-downloaded it directly from the App Store on my phone (not iTunes),

    I have a feeling it might be a hardware issue and not software, but I guess step one would be to restore your phone and set it up as new, if this doesn't fix your problem then I would suggest you to in to the Apple Store and speak to a Genius employee.
     
  3. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #3
    i also had this issue with my iphone 4 (on ios 4), and it went away after downloading any app from the app store directly from the phone.
     
  4. Pattywackk macrumors newbie

    Joined:
    Jun 18, 2012
    #4
    Hey I'm just having this problem now I don't have a warranty on my iPhone so I can't swap it out for a new one but I can't even get into my app store to try and get another new app to see if that works
     

Share This Page