at&t wi-fi calling in airplane mode works but not when cell is enabled

bbensten

macrumors newbie
Original poster
May 25, 2016
5
0
I have an iphone 6s that will only go into "at&t wifi" mode when the phone is switched into airplane mode and then the wireless is turned back on. It does not matter how weak the cell signal is (often no service) it will not come on unless I actually disable the cell. Is anyone else having this issue? The only reason I really care is that I often visit an area that literally has no cell service but the wireless network is strong. Manually entering into airplane mode and back out is easy enough but annoying.
 

avanpelt

macrumors 68030
Jun 2, 2010
2,932
3,802
Does your phone detect a strong Wi-Fi signal? No one seems to know what the exact criteria is that makes the phone switch to Wi-Fi calling when the AT&T cell network is still reachable; but anecdotal evidence suggests that the phone should switch to Wi-Fi calling automatically if the Wi-Fi signal is strong and the AT&T cell signal drops to one or two "dots".
 
  • Like
Reactions: Jetcat3

bbensten

macrumors newbie
Original poster
May 25, 2016
5
0
Very strong wifi signal. I actually find anecdotal evidence that it kicks in more frequently when the wifi signal is weaker then when it is at full strength. In my case the cell service literally says "no service". Any help is appreciated.
 

kch50428

macrumors 6502
Oct 30, 2015
320
572
North Iowa
My Verizon iPhone6 wifi calling seems to kick in when cell signal goes below two full "bars" and switches back to cellular when it's something just over two full "bars" yet less than three...
 

bbensten

macrumors newbie
Original poster
May 25, 2016
5
0
A few pictures are worth a thousand words.. Just now on my home network. Enable airplane mode, perfect. Turn off airplane mode, no att-wifi.

My Verizon iPhone6 wifi calling seems to kick in when cell signal goes below two full "bars" and switches back to cellular when it's something just over two full "bars" yet less than three...
 

Attachments

lordofthereef

macrumors G5
Nov 29, 2011
12,913
3,482
Boston, MA
Att prioritized the cell signal. This means that, if you have a usable cell signal, it will not kick in wifi calling. I believe Verizon is the same way. T-Mobile is the only carrier I am aware of that prioritized wifi calling over cell signal. This is a carrier decision and there's nothing you can do aside from voice a complaint and hope enough others do the same.
 

bbensten

macrumors newbie
Original poster
May 25, 2016
5
0
I would agree with that assessment except that it still does not kick on even when there is "no service" displayed on the phone and a full strength wifi signal. Again, if I then engage airplane mode, it will come right on in that situation too.
 

robnbill

macrumors regular
Jul 5, 2007
112
31
Northern VA - Fairfax Area
I would agree with that assessment except that it still does not kick on even when there is "no service" displayed on the phone and a full strength wifi signal. Again, if I then engage airplane mode, it will come right on in that situation too.
I have AT+T too. It always kicks in when the strength signal goes to 2 or 1 dots. It switches back and forth - and it has been 'transparent' on all calls. You may want to make sure you have latest carrier update. I think it's 24.1 -- Settings | General | About | Carrier. I think LTE plays into it too - we normally have LTE.
 

AutoUnion39

macrumors 601
Jun 21, 2010
4,890
941
I would agree with that assessment except that it still does not kick on even when there is "no service" displayed on the phone and a full strength wifi signal. Again, if I then engage airplane mode, it will come right on in that situation too.
Try restoring your phone and/or updating your carrier settings. Mine kicks in pretty quickly when I have "one dot."
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.