ATV - Airplay works from MBP, but NOT iPhone 4 or iPad!

Discussion in 'Apple TV and Home Theater' started by weslan, Dec 29, 2010.

  1. weslan macrumors newbie

    Joined:
    Dec 29, 2010
    #1
    Man,

    Seriously reconsidering my Apple TV purchase for my dear old dad. Here's the situation:

    1) iPhone 4 -- latest update as of today (12/29/10).
    2) iPad - latest update as of today (12/29/10).
    3) MBP - latest iTunes/updates as of today (12/29/10)
    4) AppleTV - brand new, out of box, latest updates as of today (12/29/10). Hard wired into the router (no wireless).

    Home sharing/most everything appears to work fine. Netflix, Youtube apps, Apple Store, all work, all gravy. Photos and music from "home shared" computers appear fine and browse fairly well and play as expected.

    Airplay'ing my iTunes library from my MBP to Apple TV behaves well. Very little lag -- it's nice and seems to act like it's supposed to. Sounds great -- exactly what I wanted.

    Airplay'ing ANYTHING from my iPhone 4 or iPad is absolutely worthless, which, unfortunately, was a huge selling point of Apple TV for me. The "Airplay" icons correctly appear when I play music from iPhone/iPad, and I can see my "Apple TV" as a valid speaker choice for both iPhone/iPad, but when I select it, nothing plays out of my TV, even though the progress bar for the song continues to play on my iOS device.

    One in three or four times, the song name will *briefly* flash on the Apple TV and it might play a second or two of the song. Most of the time it just displays "Untitled Song" and "Untitled Artist" for a few seconds before it disappears and no music comes out. It's obvious trying to play the song via the Apple TV, but it's not happening for some reason.

    Bottom line -- Airplay simply doesn't work with my iPhone or iPad, but works great from my Macbook Pro -- all on the same home network (and the ATV isn't even wireless!). I've done a million resets of my iPhone (both Network reset and full) -- iPad, and full Apple TV restores/resets. I feel like I've powered down and reset everything at least 3 times, all with the same final result.

    My best educated guess would be some router incompatibility between the Airplay technology on iOS devices and the D-Link wireless router here. But, WiFi works fine on it's own on my iOS devices here (just *NOT* Airplay).

    It's a bummer -- I'm into the Apple TV and it's potential, but like I said, this was a big selling point for me, and if this can't be resolved, it's really not worth it for me. Serious disappointment so far. Steve J, please give me a call this evening. You know the number, baby.

    Thanks!
     
  2. gdeusthewhizkid macrumors 6502a

    Joined:
    Nov 14, 2008
    Location:
    NY|NJ
    #2
    it maybe something in your router. I have a iphone 3gs and it works fine with airplay and my apple tv is wireless.
     
  3. weslan thread starter macrumors newbie

    Joined:
    Dec 29, 2010
    #3
    Anything specific? WiFi works fine on both iOS devices, but for the life of me Airplay will not stream to my Apple TV from either.
     
  4. Shuntros macrumors newbie

    Joined:
    Jun 20, 2010
    Location:
    Northern England
    #4
    Sounds like your ATV doesn't have the latest firmware. That it exactly how mine behaved until it was updated; ie. audio only, quick flash in the bottom left of the screen with song title etc.

    The clue is in settings. If it says "AirPlay Speaker", you're on the old FW. It it simply says "AirPlay" you're on the new and video should work.
     
  5. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
  6. weslan thread starter macrumors newbie

    Joined:
    Dec 29, 2010
    #6
    Shuntros,

    Thanks for the idea -- it appears it only says "Airplay" -- so, yes, I've got the latest firmware.

    Damn.

    I should also clarify that my problems appear to be confined to MUSIC (AirTunes streaming from iPod app).

    Any other guesses?
     
  7. calcfrog macrumors newbie

    Joined:
    Sep 1, 2011
    #7
    Update firmware

    I could not get Airplay to work for a couple of days. I tried everything but my router, so it had to be my Actiontec router. I updated the firmware on the router, and airplay worked immediately! It works great now!
     

Share This Page