ATV Won't Authorize Rented Movies but it will charge me!

Discussion in 'Apple TV and Home Theater' started by McVar, Mar 17, 2008.

  1. McVar macrumors newbie

    Joined:
    Mar 17, 2008
    #1
    I recently hooked up my ATV to my network (with an Ethernet cable not wireless). It worked great..allowed me to purchase music, purchase tv shows, and synced great with my iTunes on my mac book. I can browse YouTube, watch movie previews. The problem is when I rent a movie the ATV will allow me to rent the movie...iTunes charges my credit card..i can even download the movie but when I try to play the movie i get the message "Your Apple TV is not Authorized to play this content." I spent two hours on the phone with Tech support and emailed back and forth with iTunes support with no resolution. I really don't think anything is wrong with the ATV but who knows. I even hooked the ATV directly to my modem (Charter Cable is my ISP) and got the same results. Very frustrating. Has anyone else had similar problems with their ATV?
     
  2. adrianseto macrumors newbie

    Joined:
    Jun 2, 2008
    #2
    McVar, did you ever sort this out?

    This same thing happened to me last night and is pissing me off to no end! I have rented movies in the past and actually rented one yesterday morning but go home last night and rented another one and didn't work.

    I emailed tech support and they gave the usual copy and paste answer - check your connection, software update etc. I think many ppl have problems renting from itunes on their computer and transferring over to ATV. But I think our problem is different as we rented directly from ATV.

    Let me know if you have fixed this problem and can share the solution with me...

    Thanks!
    Adrian
     
  3. Eddie L. macrumors newbie

    Joined:
    May 7, 2008
    #3
    First, let me just say that I am a complete NOVICE with :apple:TV. I have owned my :apple:TV for about 2 months and I've spent the last month on this forum and the :apple: Support forums trying to work through various issues. I think that I am functioning ok now, or at least until the next issue arises.

    With that being said, have you tried deauthorizing your computer through iTunes and then reauthorizing it? I believe that you do this through the Store menu (although I could be wrong on the particular menu). I tried that as one of the possible solutions for one of the problems that I was having. After I reauthorized my computer, I believe that iTunes also reauthorizes :apple:TV as part of the next sync (or it does it automatically, but I believe it is when you sync :apple:TV the next time). I just remember seeing it "authorizing your AppleTV" in the iTunes progress bar after I performed the deauth/reauth, even though my :apple:TV was already set up and had been previously synced. This may be what is causing your problem.

    Again, this is coming from a :apple:TV newbie, but I hope this helps!
     
  4. Pandaboots macrumors regular

    Pandaboots

    Joined:
    Nov 19, 2007
    Location:
    Dallas, Texas
    #4
    Same issue here with rented movies...

    Finally bough an :apple:TV to see if it really was all it's cracked up to be. Well, so far everything has been working great. Turned it on, logged onto the home network, synced to iTunes, have streamed media with no issues, YouTube works great, searching iTunes works fine (except for the delay in the icons building sometimes) and even rented my first HD movie with no issue until I went to push play. I got the "not authorized" error message.

    A quick search on google made me think that update 2.1 was the culprit with HD rentals. So I decided to download the SD version to see if that made a difference. While it was downloading, I decided to try the already downloaded HD version one last time and voila, it began playing????:confused:

    Anyone have any insight? I did re-authorize of my iTunes account during this to try to fix it, but nothing changed immediately with the HD movie being able to play. I don't see where iTunes on my computer would even affect things, as one doesn't need a computer to rent movies. As stated before, the HD version coincidentally began working the second I re-rented it in SD. I do unplug the :apple:TV often as I don't like it sitting there so warm while not being used, so not sure if that's affecting things or if this "hobby" product is just buggy.
     
  5. Kozyinn macrumors newbie

    Kozyinn

    Joined:
    Sep 15, 2008
    Location:
    Galesburg, IL
    #5
    Possible Solution When ATV Won't Authorize With iTunes

    I have been having a similar problem all weekend where my ATV didn't seem to connect to the iTunes store. We have been using ATV for months without any problems, then WHAMO... all of a sudden it wouldn't connect to the iTunes store. I couldn't rent movies or authorize the ones I had purchased before. I thought it was some sort of connection problem or iTunes server problem.

    Today when I tried again the same issue. I knew my Internet connection was working so I tried purchasing a movie using iTunes on my computer. No problem, so what the heck is going on with my ATV??? I transferred the movie to my ATV and when I tried to play it the ATV couldn't access the iTunes store to authorize the movie. ARGH!!!!!!!!

    Solving the problem was easy enough. I deactivated my iTunes on the ATV through the settings menu. Then I simply unplugged the ATV and let it rest for a few minutes. Plugged the darn think in, let it reboot, and success. I was able to access the iTunes store, authrorize my movie, and journey back into the abyss of movie dreamland. :cool:
     

Share This Page