ATV2 works fine with remote on ATV but not with remote on itunes?

Discussion in 'Apple TV and Home Theater' started by MorgensterBE, Oct 29, 2011.

  1. MorgensterBE macrumors newbie

    Joined:
    Jun 6, 2008
    #1
    Hi all,

    I have the weirdest issue.
    Here's the background: I have one linksys E3200 router that connects one 2008 iMac, an apple TV 2nd generation and an iphone 3GS. Everything works swell except one thing: playing music from itunes to ATV . Here's the weird part. If I use apple remote on the iphone to access the ATV and ask it to play music from my imac's library it'll work flawlessly. However, if I let the remote app access the itunes library directly and ask it to stream music to the ATV from itunes the music doesn't come through. I get bursts of sound every few seconds. Movie playback does not have this issue so I'm pretty sure it's not about throughput or bandwith.

    Any ideas?
     
  2. MorgensterBE thread starter macrumors newbie

    Joined:
    Jun 6, 2008
    #2
    Anyone?

    I narrowed the problem down to this: itunes will playback music on the apple tv correctly if I pull from the apple tv and it chokes when I push from my itunes on the mac. all software is up to date and I use snow leopard.
    Pushing movies from Itunes to the apple tv works fine! WTF?

    Also, pushing music from my iphone directly to apple tv works fine.

    No ideas, anyone?
     
  3. From A Buick 8 macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #3
    How long have you had the ATV, i ask because this sounds like a hardware issue and you may need to return it.
     
  4. MorgensterBE thread starter macrumors newbie

    Joined:
    Jun 6, 2008
    #4
    I have it since januari. Although I don't see how this could be a hardware issue if I can stream movies to the device without flaw. I would expect this to be problematic if the hardare was an issue. Also, I can push music to the apple tv from my iphone and pull music from that same library when I operate the apple tv. It's only when I try to push from itunes to the apple tv that music doesn't work. Pushing movies from my itunes works fine and I'm pretty sure that takes more resources than music. So I'm pretty convinced it's an issue with settings or a bug in one of the many updates that slipped through.
     

Share This Page