Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

smithrh

macrumors 68030
Original poster
Feb 28, 2009
2,731
1,736
TL;DR: turning off Atmos in Apple Music fixes HomePod audio glitches

For perhaps 2-3 months, I've been having audio glitches on my HomePods with Apple Music, with skips or gaps ranging from extremely short (but noticeable) to around a second.

Previous to this, I had enabled lossless and enjoyed that quality level (not shockingly better, but better regardless). No skips, no issues.

Then the glitching started to occur. Not every song, but well over half. Usually in the first 10-15 seconds. Realizing this was after a software update, I figured Apple would fix it in the next release and I let it go - it was that obvious.

Then I started to notice some of the songs were really odd and different quality. I dived back into the settings to see what might be causing this, and either I had set Atmos on or Apple had defaulted it on (honestly can't remember). So I turned it off, and to be honest, while I think I was served less Atmos songs, I also didn't keep an eye on it.

The glitching continued, and a few days ago I decided to have another spin through the settings, as I had again started to notice weird quality music being played. This time I used my iPhone to see what was being sent to the HomePods, and it was indeed Atmos. So I went back to the settings and it was re-enabled. Which was odd as I had turned it off explicitly. But whatever...

What's good about all of this is that the glitching disappeared almost entirely after I disabled Atmos. I still run lossless, and have high-res selected, but I can't verify that it's being used on HomePods - but I can see it when I use my DAC and headphones.
 
  • Like
Reactions: EedyBeedyBeeps

malcky77

macrumors regular
Oct 12, 2019
247
108
I noticed audio glitches and poorer quality when listening to Apple Music on my iPhone with my AirPods when out walking the dogs....listen to music every walk...3 times a day and there was always something not right on some songs.

I think it was to do with spatial audio....so I looked for a setting relating to spatial audio on my phone and the AirPods...but couldn't see anything just for spatial audio......but there was a setting for Dolby Atmos, which mentions spatial audio.....so I turned OFF the Dolby Atmos setting in the settings section of the Apple Music app itself, and since then everything has returned back to being spot on quality wise.....keep using the lossless setting.
 

smithrh

macrumors 68030
Original poster
Feb 28, 2009
2,731
1,736
Applespeak: Atmos = Spatial

One's a brand name (Atmos), the other is the generic name. That is, you could have other spatial music, but right now Apple supports Atmos.
 

cookiemonster89

macrumors regular
Dec 13, 2012
149
158
Good to see others have the same problem. Bad side: I like the atmos mixes a lot and would like to keep the option on. I cannot believe that the HomePod OS has so many bugs.
 

muasachi

macrumors regular
Jul 29, 2013
177
336
I hate spatial audio on HomePod, so I disable it since day-one.
Still experiencing same issue tho.

My 2 HomePods sit next to the router with 750 Mb/s wifi router, but the gaps still happens from time to time.
Very annoying
 

rob2bob

macrumors member
Oct 26, 2021
59
47
I find that with Atmos toggled on and Lossless that some songs on my HomePod mini will not play with Lossless (even if available) and some do. No rhyme or reason. (I get they don’t play in Atmos as that’s on my HomePod only.)
Plus Sound Check enabled throttles the volume on the HomePod minis way too low. 70% sounds like 30%… so I have toggled off.
… all these audio glitches are bad
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.