Audiobook is in music and not in Library-> AudioBook

Discussion in 'iPod' started by VaDor, Nov 24, 2007.

  1. VaDor macrumors regular

    VaDor

    Joined:
    Feb 2, 2006
    Location:
    Portugal,Palmela
    #1
    Hi,

    I downloaded a free audiobook from iTunes store and appear in the Music Library and not in AudioBook library.

    In my iTunes the Library -> AudioBook isn't visible!


    How can I see the Library -> Audiobook and put the downloaded audiobook in there?


    Thanks :D
     
  2. Tom B. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #2
    I think the only way to do it to drag the audiobook to your desktop, and then change the extension from '.m4a' to '.m4b'
    Once you have changed that, delete the original that is still in iTunes, and then drag the '.m4b' version into iTunes. It worked for me.
     
  3. VaDor thread starter macrumors regular

    VaDor

    Joined:
    Feb 2, 2006
    Location:
    Portugal,Palmela
    #3
    I did that and He stills copies to Music section! :confused:
     
  4. Tom B. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #4
    Strange :confused:
    Maybe the last iTunes update removed this workaround. :eek:
     
  5. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #5
    Google for "Dougs Scripts" and look for a script "Make Bookmarkable". Only way I have found to turn things into audio books, for example audio books imported from a CD.
     
  6. VaDor thread starter macrumors regular

    VaDor

    Joined:
    Feb 2, 2006
    Location:
    Portugal,Palmela
    #6
    Didn't result too :(

    I think because this is PACC (protected acc) audio files and cannot be change so easily..

    They continue to stay in music :(
     
  7. MichaelAlderete macrumors newbie

    Joined:
    Nov 25, 2007
    Location:
    San Francisco
    #7
    Possible solutions

    Do you have the Audiobooks source list turned on? In iTunes Preferences > General, make sure you have the Audiobooks item checked (in the first group of checkboxes).

    If that doesn't help, I've written up a lot of instructions for using audiobooks on an iPod and in iTunes, at Aldo on Audiobooks. This includes a pretty long FAQ that covers (among other things) getting tracks to appear in the Audiobooks section.

    But, all that said, audiobooks downloaded from iTunes shouldn't need any of this attention. A while back a bunch of readers wrote in to tell me they were having similar problems to you, where purchased and downloaded books were appearing in Music. It turned out that the folks at the iTunes Store had uploaded a batch of audiobooks with the wrong metadata / tags, and there wasn't much that could be done, except contacting the iTunes Store and reporting a problem with the download. Once the tagging issues were fixed for a given book, downloading it again resolved the issue.
     
  8. bindigok macrumors regular

    Joined:
    May 14, 2007
    #8
    search for this issue, there are at least 5 other threads with this problem and fixes for it. The newest version of iTunes allows for the easiest fixes. There is no need for a script to be bookmarkable, and all m4b files will be recognized as audiobooks. But sometimes this needs tweaking. Be sure to drag the m4a files to the desktop; and then erase then from iTunes. Change the format to m4b and CONFIRM that you want to change them. Make sure they changed to m4b, then drag back into iTunes. But iTunes must have deleted the m4a and other formats of those tracks first. All m4b formats will be bookmarkable when imported. But search other threads, because there are a number of issues that have been explored.
     

Share This Page