iPhone Auto brightness and true tone aren't working on iPhone 8 (iOS 11.3.1)

Discussion in 'iOS 11' started by pineapple216, May 16, 2018.

  1. pineapple216 macrumors member

    pineapple216

    Joined:
    Apr 12, 2010
    #1
    When I updated my iPhone 8 to iOS 11.3.1, the true tone switch in the control center was gone and the auto brightness feature in General --> Accessibility --> Display Accommodations is gone as well.

    I've tried doing a soft reset as well as erasing all settings, this didn't solve the problem.
    Then I tried wiping the phone completely and restoring it from iCloud, which didn't help either.


    The features used to work in earlier iOS versions.

    Is anyone familiar with this problem?
     
  2. Banglazed macrumors 68020

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #2
    It’s possible it might be software related, you can attempt to use recovery mode. This will force iTunes to download the latest full firmware and re-write OS on the device. Put it in recovery mode by, with device powered on and connected to iTunes, quick press volume up, volume down and hold side till it reboot then release once iTunes shows its in recovery mode. Choose either update (retain your data) or restore (wipe) to first rule out software.

    Verify if problem is solved? If not, take it to Apple for further diagnostic since it may be hardware related with the faulty sensor.
     
  3. pineapple216 thread starter macrumors member

    pineapple216

    Joined:
    Apr 12, 2010
    #3
    Good suggestion.
    I just did a update from recovery mode and it didn't solve the issue.

    I guess it's a bug then in iOS 11.3.1
    I'll try to update to the 11.4 Beta 5 tonight and see if that helps.
     
  4. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #4
    Try restoring without your backup to see if that solves the issue.
     
  5. pineapple216 thread starter macrumors member

    pineapple216

    Joined:
    Apr 12, 2010
    #5
    This didn’t help either.
    Do you have any other suggestions I can try to rule out that it’s a software problem?
     
  6. aakshey macrumors 65816

    aakshey

    Joined:
    Jun 13, 2016

Share This Page