Resolved Automatic switching between Deskops - workspace auto swoosh

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
Hi guys.

I recently switched from my good old OS X 10.6 to the latest OS X 10.10 which did cause me some trouble. After some fiddling around with system-settings it is getting better. :)

But the workspace-auto-swoosh thing seems to behave different which is one pain in the a**!

You can easily turn the whole thing on/off by using the code:
Code:
defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
killall Dock
or

Code:
defaults write com.apple.Dock workspaces-auto-swoosh -bool YES
killall Dock
Now here comes the thing:

This command turns off the switchy-thing completely, which is not exactly what i want. :confused:
I only want to disable Space switching on Command-Tab (cmd-Tab) but leave everything else!

Back in the days with my good old Snow Leopard this was possible or even the default setting - i don't remember.

This behavior did come very handy if you only wanted to switch the app and open a new app-window on the desktop where you were currently working. But with Yosemite I instead end up having to switch back an forth between desktops to get there… This is not what i call a "smooth and :apple:-like workflow".

BTW: I know - there is already a similar post including the solution above: Command-Tab for Apps only in one Space?
(…)
For example, I'm in Firefox and I want a new Terminal window in the same Space. I already have several Terminal windows open. With default Spaces and CMD tabbing behavior, when I CMD-tab, I get switched to the Space of the last Terminal. This drives me nuts.
Unfortunately: All the knowledge found on google could not help me so far… maybe you can!? :)

Cheers.
 
Last edited:

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
Good idea. Thought of this myself already, but unfortunately not.

Why?
I'll give you an example:
Desktop 1 has one or two open browser-windows.
I'm working on Desktop 2 on something else (like changing some settings via terminal). That's when I'd need another browser-window to look something up.

My usual procedure was:
cmd-Tab - in order to switch to the browser-app,
cmd-N - and there is my new browser-window.

At the moment:
I first have to switch back to Desktop 1 (where the browser-windows are) - manually or by auto-swoosh, then open a new window (cmd-N) and then drag it to Desktop 2, where I need it.

This procedure it's a bit complicated and annoying.

Furthermore there still was that "auto-swoosh"-option if you needed it:
:)
Example:
If you are looking for a window you know you have sitting around somewhere on one of your desktops but don't remember where (e.g. the Activity Monitor) … yep - does happen from time to time ;) … you could easily find it by using the "auto-swoosh" which brings you there when double-clicking the app-icon in the dock.
 

h9826790

macrumors G5
Apr 3, 2014
13,470
6,175
Hong Kong
If force the browser always open in Desktops 2 is not an option for you, may be install a separate browser app, and use it only with terminal may help.
 

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
Possibilities

A second browser.app would be possible… but also not much easier than manually opening/moving the windows to other workspaces. (Not to mention the additional resources required.)

Locking the (browser) app to a certain desktop wouldn't help as I have (browser) app-windows on almost every desktop. Btw. I have the same problem with finder-windows, … :)

The best solution would be if there was some way to disable the auto-swoosh only for the cmd-Tab command - but keep the desktop-auto-switching enabled for all other trigger actions, e.g. when klicking the app-icon on the dock.

OR

Is there a something like a list of actions that trigger the auto-swoosh function which can possibly be edited and thus gives you the option to disable the cmd-Tab as a trigger??

OR

I now found another workaround here … but it's still not the smoothest way when you are used to the quick, old way with keyboard-shortcuts…
1st: keep workspaces-auto-swoosh turned ON - gives you the options mentioned above to "find a lost window" :)
2nd: In case …
… you'll still have to open a new window for the application though: Click the application in the dock, then press cmd+n.
- this seems somehow not to trigger the auto-swoosh, which means you stay on the desktop you are working on.

Edit: It DOES also trigger the auto-swoosh --> no possible solution.

Hm … I wonder if nobody else misses the combination cmd-Tab and then cmd-N to get an new app-window? Who does those improvements for the worse … :rolleyes:
 
Last edited:

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
Solved

Found another old Thread on Mac OS X Hints which states that the problem already existed in OS X 10.5.

This did make me think of reviewing the default settings of my OS Installation in: system preferences > mission control

Just uncheck the box next to:
"When switching to an application, switch to a Space with open windows for the application"
… done. Easy as this. :D

Now you can cmd-N to switch the app without being bothered by auto-switch. You just stay on the desktop where you have been working…

Sometimes settings are just hidden too far away :p

BTW: Here is another very good summary on the topic "Stop auto-switching in Mission Control"
 

citivolus

macrumors 6502a
Sep 19, 2008
765
87
But the workspace-auto-swoosh thing seems to behave different which is one pain in the a**!

You can easily turn the whole thing on/off by using the code:
Code:
defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
killall Dock
or

Code:
defaults write com.apple.Dock workspaces-auto-swoosh -bool YES
killall Dock
Now here comes the thing:

This command turns off the switchy-thing completely, which is not exactly what i want.
Does this actually work in Yosemite? I tried it and no luck...

My problem is that the animation when switching between workspaces gets choppy...occasionally it will actually get stuck in between two workspaces!

I just want to disable it--any ideas?
 

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
@ cititvolus: Yes it works. Maybe you need admin rights for this change. In this case try it with:

Code:
sudo defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
Code:
killall Dock

The command above turns off automatic desktop switching. But you still have several workspaces or "spaces" - as they were called in the good old days. I'm not sure if Yosemite has an option to completely turn off its multi desktop function - never needed that.

Son-Y.
 

citivolus

macrumors 6502a
Sep 19, 2008
765
87
@ cititvolus: Yes it works. Maybe you need admin rights for this change. In this case try it with:

Code:
sudo defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
Code:
killall Dock

The command above turns off automatic desktop switching. But you still have several workspaces or "spaces" - as they were called in the good old days. I'm not sure if Yosemite has an option to completely turn off its multi desktop function - never needed that.

Son-Y.
Thanks, I tried that and it still didn't work. Just to be clear, I am running Yosemite 10.10.2 and executing the commands as an admin and they are applied. I am just not seeing the behavior change, namely when I command-tab to an application in another workspace, the UI "slides" to the corresponding workspace in an animated fashion. I just want to disable the animation and have the UI instantly display the corresponding workspace.

Son-Y, is that what you are able to accomplish with the above commands?
 

Son-Y

macrumors newbie
Original poster
Jan 21, 2015
7
0
The commands above are for turning off the automatic switching-function globally or when triggered by changing the app.


But what you want is to disable the animation. Not the autoswitch-function itself.
- Just like you can turn off those application opening animations in the dock-preferences.

I can't tell you if this is possible. Could be intersting. Less animations and optical fluff could make a Mac faster and less distracting :D
If you find out, let me know!

Son-Y.
 

KFrench

macrumors newbie
Feb 24, 2017
1
0
Hi guys.

I recently switched from my good old OS X 10.6 to the latest OS X 10.10 which did cause me some trouble. After some fiddling around with system-settings it is getting better. :)

But the workspace-auto-swoosh thing seems to behave different which is one pain in the a**!

You can easily turn the whole thing on/off by using the code:
Code:
defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
killall Dock
Cheers.
Dude! You saved my life! I was so saddened when nothing would turn this feature off. This code does the trick! THANK YOU!
 

brendancbozman

macrumors newbie
Apr 14, 2017
6
0
Dude! You saved my life! I was so saddened when nothing would turn this feature off. This code does the trick! THANK YOU!
Likewise! so glad i found this. It was annoying as hell having the autoswap and by the time you'd get bck to the screen you were previous, you'd forget what the eff you were even doing. Now I can keep my focus in peace haha
 

bnaman

macrumors newbie
Dec 17, 2018
1
0
I wanted to enable this feature i.e. set it to default behavior. For this, I used the following command -

defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
killall Dock


I checked the values just to make sure that the command worked using

defaults read com.apple.Dock workspaces-auto-swoosh

and it shows the value to be 1. But the thing is it does not enable the default behavior.

After this, I opened my Guest account and there this feature was working properly. I again checked the value using the read command and this time it showed that the value does not exist (or something similar). Thus, I tried to delete this value using

defaults delete com.apple.Dock workspaces-auto-swoosh

and when I looked at the value using read command, the result was similar to my guest account. But this still does not enable the default behavior.

Has anyone tried this?
 

Djeross

macrumors newbie
Dec 5, 2018
3
2
Hi @bnaman,
I was searching for the same thing, and found out that this setting has changed.
The new one is in Global Prefs:
defaults write -g AppleSpacesSwitchOnActivate -bool false (or true)

I don't know in which version it changed, and I don't know if the old one still has any use.
Let me know if this helps you.