Resolved Automator won't launch anymore…

Discussion in 'Mac Apps and Mac App Store' started by Nord, Mar 22, 2014.

  1. Nord, Mar 22, 2014
    Last edited: Mar 23, 2014

    Nord macrumors member

    Nord

    Joined:
    Apr 28, 2010
    #1
    Hi everyone.

    I'm in need of assitance, as I'm runnig out of ideas how to solve this issue.

    A few days ago, Automator crashed after running quite a huge script I created (but nothing fancy, just reproducing a calendar event 100 times, but it was quite a long window). After that, it refused to reopen no-matter what I tried. Sometimes, a messag ecomes: "relaunch windows ?" I tried with yes and no, no result. Generally, I click the icon, no window opens, going to the menu bar brings the colored spinning wheel, and then i closes itself after a few seconds.

    I already check a few forums about it and tried the following:
    Tried to launch it after repairing disk permissions > it failed
    Tried to launch it through the Guest account > it worked.
    Tried to launch it in safe mode > it worked
    Tried to relaunch it in normal mode > it failed
    Tried it after removing all Preferences files > it failed
    Tried to restore a working version of Automator with Time Machine > it failed
    Tried reinstalling Mavericks (not erase and reinstall) and launch it afterwords > it failed


    I don't know what to do now. It can't be I have to erase & reinstall everything just for one little app. Even though, I don't know if that would help, since reinstalling Mavericks made no difference. Is there a way to reinstall jsut Automator from the Guest account or newly created account ?

    I'm stuck and would really appreciate your help.
    Thank you very much.

    N.b. I don't have my Time Machine backup anymore.
    iMac 27'' late-2012 on Mavericks
     
  2. kryten2 macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #2
    Reboot your Mac. Check the logs in the Console application as to why it crashes. The fact that it works from the guest account is a good sign. There's is only one Automator application so restoring it from the guest account is not an option. The guest account uses the same Automator application as you do with your user account. You can also reinstall the 10.9.2 update or extract Automator from the update with something like Pacifist.

    Info : http://www.charlessoft.com/

    Note : Whatever you did to make it crash, don't do it again. Look at Applescript for things like reproducing a calendar event 100 times.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Confirm you logged in to your account in safe mode and it works, bit logging in to the same account in regular (non-safe) mode it does not work?

    Safe mode bypasses any login/startup items for the selected account. So the fact that to works in safe mode but not in regular mode for the same accounts tells us you may have a startup item that is causing this issue.

    Try removing startup/login items half at a time until you find the culprit.

    Another idea... how did you save the automator action after you made it?

    Open Finder then Go menu then Go to folder and paste this in and enter. Look in that folder and see if the Automater action is running as a service and delete it then restart.

    Code:
    ~/Library/Services
     
  4. Nord thread starter macrumors member

    Nord

    Joined:
    Apr 28, 2010
    #4
    Thanks kryten2 and Weaselboy for your quick answers ! Your answers kind of relieved me and hope I can solve this soon. I'm no expert, so I'll try to answer as best I can.

    @ kryten2
    Actually, I did nothing particular. I used a regular pre-instaleld script for the Calendar app, copied it 100x and changed the dates and time. I launched it within the app, like I've done it hundreds of time, and after executing it all correctly, at the end it just crashed.

    I've heard of Pacifist, but I thought it extracted apps from the DVD of OS X. How does it work in Mavericks ?

    @Weaselboy: yes, I confirm. I did it in this order: Safe Mode, then normal mode, same account.

    I actually could save the file when I was in Safe mode. I was hoping, this would help, but then I couldn't open Automator nonetheless note open any Automator Script I had previously saved.

    I have no Automator action running in the Service folder in the Library.
    I will try to remove a few starting apps and will report back.

    Thank you both for you time.
     
  5. Nord thread starter macrumors member

    Nord

    Joined:
    Apr 28, 2010
    #5
    Problem solved.

    The problem was solved in an other forum. (See here)
    Thanks to all for your help.

    Let me give you a recap (copy-paste) of my last post, should this also happen to you.

    The console showed in the crash report a link to a Office.definition file. I erased the Office.definition file and made sure there's no more file concerning Automator in :
    ~/Library/Saved Application State
    ~/Library/Calendars
    ~/Library/WorkFlows/Applications
    ~/Library/Application Support
    ~/Library/Preferences
    ~/Library/Caches

    I also found some file about Automator in

    ~/Library/Autosave Information


    and erased everything before trying to re-open it, but it still didn't open.

    I then realized there are still some locked files of my previous backup in the trash that wouldn't go away which had some Automator files inside (red_menace told me some files may still be linked, eventhough they're already trashed). I then when into Safe Mode. I forced deleted the Trash by pressing the alt key at the same time. Made sure everything did infact erased by chekcing every single folders once again. Restarted the Mac in normal mode and tried to open Automator and it worked !
    So there must've been some file in the trash that was messing up with Automator.

    In short, Mavericks does seem to use files also in the trash to load active application. They will work until they are permanently erased.

    Thank you all for your help !
     
  6. kryten2 macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #6
    Glad you got your problem solved. Thanks for the follow up and posting the solution.
     

Share This Page