Azureus through Airport Express and NetGear DG834GT, on Sky Broadband

Discussion in 'Mac Accessories' started by TheHonestLawyer, Nov 14, 2007.

  1. TheHonestLawyer macrumors newbie

    Joined:
    Nov 14, 2007
    #1
    Not sure if this is all that relevant here, but I just had to put this out there. I'm on a Mac, using Sky broadband on a netgear DG834GT and an airport express, and it took me 7 hours to work out how to set Azureus to work. I found many threads saying that you can set the NetGear DG834GT to operate in bridge mode rather than router, which makes life so much easier for most. But I couldn't do that on mine, and I subsequently found out it was because Sky have disabled that option on their routers for some reason (why is just beyond me...). So here was my solution, for anyone else with a similar problem.

    Step 1. Configure Static IP address:

    Follow instructions on: http://www.portforward.com/networking/static-Mac10.4.htm


    Step 2. Configure Port Forwarding for NetGear Router:

    http://portforward.com/english/routers/port_forwarding/Netgear/DG834GT/Azureus.htm

    Note! For Sky routers:
    User Name= admin
    Password= sky

    Step 3. Configure AirPort Express. I got the basis for this from http://forums.macrumors.com/archive/index.php/t-124166.html, but I had to change quite a few of the configurations (because I couldn't set the netgear router to bridge mode), so I'll just give you the complete instructions of what you have to do (a lot of copy/paste from the above site; no plagiarising) (sorry, I'm a law student, prone to that kind of paranoia:

    Set up the Airport for port forwarding:

    Part (a) Log into Airport Admin Utiity, and choose the Network tab. Choose Distribute IP addresses, and Share a SINGLE IP address. Then choose use 192.168.1.1 addressing.

    Part (b) Under the Airport tab, choose Base Station Options. Tick the following:

    Enable SNMP Access
    Enable Remote Configuration
    Enable Default Remote Host at 192.168.1.203 (not sure about this, I read somewhere that this is dangerous. I tried unticking this option and everything still worked fine)
    Enable NAT Port Mapping Protocol

    Part (c) Goto the Internet tab. "Connect Using": Ethernet. "Configure": Manually. Then enter the exact same IP address, subnet mask, router address and dns servers as for step 1.
    e.g:
    IP address: 192.168.0.10
    Subnet mask: 255.255.255.0
    Router address: 192.168.0.1
    DNS servers: 212.135.1.36
    195.40.1.36

    Save the configuration.

    Your internet connection won't work now: you need to give your computer the fixed IP address chosen above. To do this:

    Part (d) Goto System Preferences, Network, Show: Airport, then TCP/IP.

    Your connection will probably be set up Automatically using DHCP.

    First, make a note of the Subnet Mask (will probably be 255.255.255.0)

    Then, change the Configure IPv4 tag to: Manually, and enter the following:

    IP Address: 192.168.1.x (where x is anything, e.g. 10)

    Subnet Mask: (whatever you noted above, eg: 255.255.255.0)

    Router: 192.168.1.1
    (this is the Airport's IP Address, should practically be the same as the router's, apart for the penultimate digit, i.e. router=192.168.0.1 and airport=192.168.1.1)

    DNS Servers: your ADSL provider's servers (see above for Sky)

    Part (e) Save the settings (Apply Now) then goto Show All and Sharing, then choose the Firewall tab.

    Ensure the Firewall is ON, then choose New... and enter:

    Port Name: Other
    Port Number, Range or Series: whatever port you chose in step 2
    Description: Azureus (or whatever you feel like calling it)

    Note: make sure it's ticked in the list

    And that's pretty much it, everything has been working fine since. I hope some of this is helpful.
     
  2. Problem Child macrumors newbie

    Joined:
    Mar 8, 2007
    #2
    Thanks for this just what I needed, I'll be trying this out. I just need my express to be working with my router. I got it to connect to the router, but then I can't connect to the express.
     

Share This Page