bad battery? Won't boot without charger right out of box

Discussion in 'MacBook Pro' started by dimabear, Jun 3, 2014.

  1. dimabear macrumors newbie

    Joined:
    Jun 3, 2014
    #1
    Just got my 6th rMBP (all previous 5 were returned for various reasons such as yellowish display, poor battery, creaking, etc). This one is the 15" 2.3 16gb 512gb model whereas the other rMBP were all base 15" models.

    When i tried to start this rMBP, it would not start. At first i thought I didn't press the button enough and so I pressed it several times. Got worried and then plugged it in and pressed the button...still would not start then after about 20 seconds of charging, it started.

    After going through all the setup processes, the battery says 4% charge. This is the first time ever i've bought an apple laptop since 2004 that wouldn't start. I can understand the laptop not being fully charged, but 4%? That, to me, is a bit odd and low.

    Has anyone else had that experience? Is this normal? It's now charging and says about 3 hours until full charge. I'm a bit worried though b/c it is indeed very warm (the laptop surface by the esc key and power adapter, as well as magsafe2 adapter (i'm using the charger of apple 27" display). I'm a little worried that I've got a bad battery.

    One of the previous 5 rMBPs had a bad battery while the other rMBPs had amazing battery (8+ hrs of safari, itunes, ical, wifi, etc).

    I did read the higher spec rMBP runs a bit warmer b/c of the dedicated graphics.

    has anyone else had this issue? should i be worried?

    it's a LG display but so far no image retention and no yellowing which is good
     
  2. SVTmaniac macrumors 6502

    Joined:
    Jan 30, 2013
    #2
    6 MacBooks? you're joking right? You're either the unluckiest person on the planet, or every other person with a MacBook is extremely lucky. Or you're just way too picky. One of those sounds the most reasonable to me.
     
  3. dimabear thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #3
    Yes that's right-all had problems. why pay $2k+ if it's not correct? My 2010 classic MBP doesn't creak, nor has a yellowish screen. A side by side comparison of the same website clearly show the 2010 mbp had more true whites than a 2013/2014 rMBP. and why some rMBP go 4 hrs while others go 10+ hrs? don't know about you, but if I'm spending $2k+, it better work correctly. Oh, and the 3rd rMBP showed a hardware message code than even the apple phone tech said he'd never heard of and just to exchange it.

    I'm worried bc all apple laptops I've bought started without the charger the first time. This one did not until I plugged it in. And it was then I discovered it had only a 4% charge.
     
  4. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #4
    So what? Charge it back up and call it a day.
     
  5. dimabear thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #5
    Yes that's what I did. I charged it overnight to full charge and I get about 7.5 hrs it says if I don't do anything. Odd, b/c the other rMBPs said 10+ hrs if I did nothing.

    what I'm asking is if anyone else has had this issue before - laptop not starting for first time without the charger. and if someone has experienced this, did they have any battery issues?

    My concern is that I could have a bad battery that drains prematurely even if doing nothing at all (I.e. Sleep/off etc)
     
  6. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #6
    You have 1 full year of warranty to test that out. Just use your computer for the moment and you'll see soon enough.
     
  7. dimabear thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #7
    According to the serial number, this laptop was built in Feb 2014. If i'm not mistaken, my understanding is that the laptop ships with *some* battery life. Assuming that is true (based on experience with several laptops from apple and various vendors over the years), then that means from the day this laptop was built (Feb'14) and sitting in a box all the way up to the purchase date (Jun 2 2014) the battery went to empty. That's the point i'm trying to make. That to me, is a concern. Unless... this laptop was used before, then re-packaged as "new"....

    One of the base 15" rMBPs i purchased (and subsequently returned), had some wear marks around the usb ports, power adapter cable, and also had a small wire sticking out of one of the vents.

    And I have pics to verify this as well, which i gladly showed the apple store when i returned each and every one....

    ----------

    i'm very picky, and especially more picky when i'm spending $2k
     

Share This Page