Bad public movie atom was found in the movie Error in Quicktime

Discussion in 'Mac Basics and Help' started by Avi, Apr 10, 2009.

  1. Avi macrumors member

    Feb 28, 2009
    Hello folks

    I have about 2-3 movie files (.mp4) which when I try to play in Quicktime I get the "bad public movie atom was found in the movie" error.

    So I cannot playback those movies on my Front Row .... its frustrating ... Is there any way to fix this?

    I tried zipping up the file and unzipping it as suggested in other sites but that did not work.

    I also tried using Tagger to edit the Metadata and re-saving the file, that did not work either.

    Finally, I used AoA Mp4 Patch, which claims to fix such issue ... that failed too.

    Btw, all of these files play perfectly well in VLC ... but I want to view them on Front Row ... any help will be greatly appreciated!

  2. Avi thread starter macrumors member

    Feb 28, 2009
    After 2 day still no reply ;)

    So after a lot of frustrating hours searching the web for a solution ... I decided to re-encode the video and see if it could be Compatible with Quicktime.

    I am using Handbrake, I imported the video to Handbrake, I am saving it as a .M4V (so that it can be read in iTunes 'n Quicktime). As far as the Audio settings are concerned, I am selecting "Unknown AAC() " Option ... is that incorrect?

    Coz I end up with a .M4V video that plays beautifully in Quicktime and iTunes but no Audio!!!

Share This Page