baseband 4.05.04_G - But I need to unlock for T-Mobile

Discussion in 'Jailbreaks and iOS Hacks' started by Denaes, Jul 14, 2008.

  1. Denaes macrumors newbie

    Joined:
    Jul 14, 2008
    #1
    I'm very new to the iPhone.

    My roommate just got a new 3g and gave me his 2g to see if I could get it working with T-Mobile.

    The catch was that while he had it all jailbroken (not simunlocked as he had AT&T) he had just upgraded to 2.0 for a day to check out the apps.

    It's taken me about a day to get the iPhone from 2.0 to 1.1.4. I had to do this by using iTunes 7.7 to downgrade from the official 2.0 release to a prior 2.0 release, then to 1.1.4.

    The baseband is 4.05.04_G and apparently I need it to be lower to I can us the phone.

    I've run KiPhone (the hacked ZiPhone baseband downgrader) about a dozen times. 90% of the sites I find mention this specific software and that it might take multiple tries. I've tried to downgrade and erase.

    I've also run BootNeuter downloaded from installer and keep getting an Error 5.

    I've tried to reload 1.1.4 a few times to see if that helped at all.
    So I'm just not sure what else I could try?

    Thanks for any advice on this
     
  2. KP1PBR macrumors newbie

    Joined:
    Jul 22, 2008
    #2
    4.05.04_G baseband problems

    I'm experiencing the same exact problem and have performed the same actions.
    - Sucessfully restore 1.1.4
    - Unable to use kiphone. It launches to GUI and blanks out when I click start.
    - Unable to use bootloader b/c it gives me a (5) error message.

    I beleive the kiphone is the fix but it will not run on my Vista machine. Can someone shed any light onto this situation?

    Thank you
     
  3. carfac macrumors 65816

    carfac

    Joined:
    Feb 18, 2006
    #3
    Have you tried pwning it with pwnage 1.0? That adds a bootneuter program that can flash the baseband to 3.9 or 4.6....

    DOn't know if it will help, but it might!
     
  4. macdim macrumors 6502

    Joined:
    Oct 16, 2007
    Location:
    Canada
    #4
    Why do you need to do this now that firmware 2.0 has been pwned? Pwnage tool 2.0.1 will unlock, activate and jailbreak your iPhone on 2.0...
     
  5. jeffmc macrumors 6502

    Joined:
    Sep 21, 2007
    #5
    3.9 and 4.6 is a BOOTLOADER not a baseband
     

Share This Page