Battery Drain with Find My Mac Enabled

Alicia1

macrumors 6502
Original poster
Nov 13, 2009
287
195
Gold Coast, Australia
Hi All

Before I call Apple I was wondering if anybody would have any ideas why my 2018 mbp keeps draining battery and stays awake ONLY when Find My Mac is enabled.

I did a clean install when Mojave was released (haven't done another one since), I have reset smc etc, logged out of icloud and back in again and no matter what I do if Find my mac is enabled and I close the lid it won't sleep and the battery drains (doesn't happen all the time but probably around 90% of the time). As soon as I turn off find my mac, everything is ok.

I just don't get it :( I have never had this issue before.

If anybody would have any ideas I would really appreciate it.

Thanks :)
 

Howard2k

macrumors 68030
Mar 10, 2016
2,900
2,158
While on battery power (mains unplugged) from terminal run pmset -g and see what the values for standbydelaylow and standbydelayhigh are.
 

Alicia1

macrumors 6502
Original poster
Nov 13, 2009
287
195
Gold Coast, Australia
this is what I get

standbydelaylow 10800

standby 1

halfdim 1

hibernatefile /var/vm/sleepimage

proximitywake 0

powernap 0

gpuswitch 2

disksleep 10

standbydelayhigh 86400

sleep 2

hibernatemode 3

ttyskeepawake 1

displaysleep 2

tcpkeepalive 1

highstandbythreshold 50

acwake 0

lidwake 1
 

Isamilis

macrumors 6502a
Apr 3, 2012
730
140
Hi All

Before I call Apple I was wondering if anybody would have any ideas why my 2018 mbp keeps draining battery and stays awake ONLY when Find My Mac is enabled.

I did a clean install when Mojave was released (haven't done another one since), I have reset smc etc, logged out of icloud and back in again and no matter what I do if Find my mac is enabled and I close the lid it won't sleep and the battery drains (doesn't happen all the time but probably around 90% of the time). As soon as I turn off find my mac, everything is ok.

I just don't get it :( I have never had this issue before.

If anybody would have any ideas I would really appreciate it.

Thanks :)
I solved battery drain issue by fresh install Mojave, BUT not to activate iCloud / input Apple ID during installation (just select skip). Once you are sure no draining issue then activate the iCloud with selective apps. I turn on Find My Mac.
 

Howard2k

macrumors 68030
Mar 10, 2016
2,900
2,158
this is what I get

standbydelaylow 10800

standby 1

halfdim 1

hibernatefile /var/vm/sleepimage

proximitywake 0

powernap 0

gpuswitch 2

disksleep 10

standbydelayhigh 86400

sleep 2

hibernatemode 3

ttyskeepawake 1

displaysleep 2

tcpkeepalive 1

highstandbythreshold 50

acwake 0

lidwake 1

I had the same problem. I had to adjust the standby timing.

standbydelayhigh 86400 is 24 hours. Maybe consider changing those to 1 hour (3600)

To do that, back on battey again run:
Sudo pmset -b standbydelayhigh 3600

And also set standbydelaylow to 3600 too.

Then verify by running pmset -g again and ensure those values stuck.
 

Alicia1

macrumors 6502
Original poster
Nov 13, 2009
287
195
Gold Coast, Australia
Thanks will try that when I get home from work. It is strange as it only happens with find my mac enabled. As soon as I turn that off, no issues.
 

inkhorn

macrumors regular
Oct 8, 2009
118
54
Ive changed my settings to hibernate when on battery after 2 hours (when above 75%), and after just one hour when the battery level is below that.

Set :
Code:
 $ sudo pmset -b highstandbythreshold 75
 $ sudo pmset -b standbydelayhigh 7200
 $ sudo pmset -b standbydelaylow 3600
Verify :
Code:
$ pmset -g custom | grep -E 'Power|standby\w'
Battery Power:
 standbydelayhigh     7200
 standbydelaylow      3600
 highstandbythreshold 75
AC Power:
 standbydelayhigh     86400
 standbydelaylow      10800
 highstandbythreshold 50
 

inkhorn

macrumors regular
Oct 8, 2009
118
54
Well, this didn't seem to help at all overnight, so I've also reluctantly set
Code:
$ pmset -b tcpkeepalive 0
 

Howard2k

macrumors 68030
Mar 10, 2016
2,900
2,158
Well, this didn't seem to help at all overnight, so I've also reluctantly set
Code:
$ pmset -b tcpkeepalive 0

Sorry to hear that. I can confirm that I have tcpeepalive enabled. Here are my settings for battery:

System-wide power settings:

Currently in use:

lidwake 1

autopoweroff 1

standbydelayhigh 2700

autopoweroffdelay 28800

proximitywake 0

standby 1

standbydelaylow 2700

ttyskeepawake 1

hibernatemode 3

powernap 0

gpuswitch 2

hibernatefile /var/vm/sleepimage

highstandbythreshold 50

displaysleep 5

sleep 5 (sleep prevented by iTunes, sharingd, backupd, coreaudiod)

acwake 0

halfdim 1

tcpkeepalive 1

disksleep 10
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.