Battery drains fast when 3G on

Discussion in 'iPhone' started by Tex-Twil, May 30, 2013.

  1. Tex-Twil, May 30, 2013
    Last edited: May 30, 2013

    Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hi,
    my iPhone 4S has been working fine until some weeks ago where I realized that my battery drains super fast when the 3G is on.

    Even when I do not use the iPhone, it takes only some hours to kill the battery.

    I'm on iOS 6.1.2 (jailbroken). I'm waiting for SemiRestore to be available to try a restore of the device. I'd like to avoid updating to 6.1.3 since there is no JB for it.


    Any idea what could be the reason?

    cheers
     
  2. ValerieDurden macrumors 6502a

    Joined:
    Feb 3, 2010
    Location:
    Philadelphia, PA, USA
    #2
    What is your service provider and what kind of signal are you getting?
     
  3. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #3
    The most logical question to ask is: what jailbreak-specific stuff do you have installed? Maybe one of those tweaks/apps/etc. is using 3G?
     
  4. Baggio macrumors 6502

    Joined:
    Oct 18, 2012
    #4
    Have you tried a hard reset on the phone? Hold the home/power buttons until the Apple logo appears.
     
  5. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #5
    I have O2 (Germany) with a good signal but I don't think it matters.

    Not much. BiteSMS and NCSettings. I had those before as well when the battery was ok.


    ok, I'll try that.
     

Share This Page