Battery Life/Usage??

Discussion in 'iPhone' started by lupend88, Oct 12, 2012.

  1. lupend88 macrumors 6502

    lupend88

    Joined:
    Jul 13, 2010
    #1
    My battery went from 100%-70% in less than 1.5 hours of usage. Is this normal?

    Bluetooth Off
    Wifi On
    Brightness 65%

    [​IMG]

    Thanks in advance for the help!
     
  2. epphllps macrumors 6502

    Joined:
    Mar 13, 2011
    Location:
    West TN
    #2
    My advice is to do a dfu restore. I did ALL suggested resets and settings adjustments since 9/21, but today I did a dfu restore and all I can say is WOW. There has been a world of difference so far with the same usage patterns. Give it a shot and set up as new.
     
  3. lupend88 thread starter macrumors 6502

    lupend88

    Joined:
    Jul 13, 2010
    #3
    Do you mind explaining to me how to do so? Would you agree my battery life is subpar?
     
  4. CatsTide macrumors 6502

    Joined:
    Sep 16, 2012
    #4
    Yes it's normal since your phone has been off the charger for almost 12 hours.
     
  5. lupend88 thread starter macrumors 6502

    lupend88

    Joined:
    Jul 13, 2010
    #5
    How much of a difference does that really make? It's been asleep in my pocket for 90% of the day.
     
  6. CatsTide macrumors 6502

    Joined:
    Sep 16, 2012
    #6
    sleeping phone uses battery too. Really doesn't look bad to me.
     
  7. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
    #7
    Yep, hour and a half of WiFi usage and being off the charger for 12 hours that's a pretty average result.
     
  8. lupend88 thread starter macrumors 6502

    lupend88

    Joined:
    Jul 13, 2010
    #8
    Ok, but a DFU restore wouldn't harm anything either right? I have been having other problems besides battery life with my iPhone 5, including...

    -Photos in Messages won't load, it's stuck at the Loading circle bar
    -iMessage won't send on Wifi, has to resort to LTE
    -Sometimes people say they called me and it goes to voicemail without me ever receiving a call

    Could a DFU restore fix these?
     

Share This Page