Beige G3, OSX Disk Utility Freeze

Discussion in 'Mac Apps and Mac App Store' started by FoxyKaye, Jul 30, 2004.

  1. FoxyKaye macrumors 68000


    Jan 23, 2004
    Livermore, Terre d'Ange, Bas Lag, Gallifrey
    Hi All,

    I've been having this weird problem with Disk Utility in OSX on my Beige G3: Specifically, after *much* trial and error, I've noticed that if I run "repair permissions" it has a tendency to freeze if left unattended. HOWEVER, if I run "repair permissions" and do other things like surf the Web, check email, work in Excel, and/or listen to iTunes, it doesn't freeze and my permissions are accordingly repaired.

    Also, as a footnote, I've also noticed that rebooting after repairing permissions hangs the system in a perpetual boot-loop. I then have to manually power off and restart, after which it boots and runs fine.

    Anyone else have this problem, or is it just a ghost in the machine?

    My system specs are below...

  2. oldfart macrumors member

    Jul 30, 2004
    Re: Disk Utility Beige G3 (4) Freezes

    Couple of things come to mind: In my limited experience with Beige G3's, (upgraded or not), the biggest problem seems to be RAM. If the RAM is incorrect or faulty, you will hang when you use Disk Utility.

    Try booting from the OS X Install Disk 1 and after you get the screen go to the pull-down menu and select Disk Utility. Run it from the Installer Disk. If it hangs (goes to black screen or your monitor lamp goes amber), more than likely you have a RAM problem.

    Remember too, that if you install software and don't repair permissions after each install (restart immediately after rebuilding permissions), you may experience these problems again.

    There's more, but this should be a start. Hope it helps.
  3. oldfart macrumors member

    Jul 30, 2004
    ....thought about it and thought about it.....:cool:If you can boot to OS 9:( and get a copy of "Disk Warrior";) or better yet "TechTools";) (OS 9 Version for either), run "Disk Warrior" to repair the directory structure or File Structure under "TechTools". It's slower than you can immagine, but be patient, it will eventually "fix" everything :) Reboot to OS X and repair permissions. If it hangs there, then download "Cocktail" and run it. When "Cocktail" starts, click on the "Pilot" icon and click "Run" ;) . When it's finished, immediately restart your computer. :p

    Hope this works!! :)

Share This Page