Best still supported OS to use on MacBook 4,1 with 2.4Ghz Intel 2 Core Duo and 4GB SDRAM?

Discussion in 'Windows, Linux & Others on the Mac' started by brittmartin, Apr 18, 2018.

  1. brittmartin macrumors newbie

    Joined:
    Mar 13, 2015
    #1
    Currently this machine is still running OS X 10.7.5 but I'd like to use a still supported OS.

    Any recommendations for something that works well?
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #2
    With those specs, I can only say Linux, as everything else would be too slow to use.
     
  3. brittmartin thread starter macrumors newbie

    Joined:
    Mar 13, 2015
    #3
    What distros of linux would be best? I'm not familiar with Linux at all but would be willing to learn if needed.

    So Windows wouldn't work well at all?
     
  4. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #4
    Any supported Windows OS will be slow, but you could try it for free.

    Many people enjoy Ubuntu or Linux Mint. Two of the lighter weight spins of Ubuntu are Lubuntu and Xubuntu. You can simply boot those ISOs to try them out.
     
  5. EugW macrumors 603

    EugW

    Joined:
    Jun 18, 2017
    #5
    What's the easiest way to install Windows 10 on MacBook4,1? Dual boot with OS X is not necessary.

    I currently have Chrome OS (Neverware CloudReady) on it, and it works fine for the most part, but the WiFi drivers provide slow throughput and Netflix is flaky on the machine. Surfing, email, and Office work fine though.
     
  6. EugW macrumors 603

    EugW

    Joined:
    Jun 18, 2017
    #6
    I just loaded up Linux Mint on my MacBook4,1. WiFi doesn't work at all, and when I plug in Ethernet from the MacBook into my AirPort Extreme, it takes down my entire network. Unplug Ethernet, and everything's fine again. I'm wondering if my MacBook is trying to act as a server or something.

    Also, if I leave the machine a while and then try to come back to it, there is a long delay before the trackpad pointer works again. Yeah, I'm running off USB, I don't have these delays in Chrome OS.
     
  7. EugW macrumors 603

    EugW

    Joined:
    Jun 18, 2017
    #7
    Tried Ubuntu. WiFi didn't work either from the USB boot drive, but the cursor delay wasn't there. I then fully installed Ubuntu and used the Additional Drivers menu to install the proprietary Broadcom driver and now it works, with faster speeds than I was getting with Chrome.

    Netflix works fine in Ubuntu once you install the DRM files, which is automatic once you agree to it. Not surprisingly, Netflix HD on MacBook4,1 ramps up the fans. So far it also seems stable. The problem on Chrome is that was a bit iffy.

    The other thing is that there seems to be better compatibility in Firefox with some sites using Ubuntu 17.10. On Linux Mint (which I believe is based off Ubuntu 16.x LTS), www.speedtest.net wouldn't work, but it works fine in ubuntu.

    I can't figure out how to right-click the trackpad button though. CTRL-click and OPTION-click and COMMAND-click still just give me the left click.
     
  8. Riwam, Apr 22, 2018
    Last edited: Apr 22, 2018

    Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #8
    My long answer is not what you ask, a still "supported" OS (at least not by Apple) but I am just posting it for whatever it might be worth for you...

    Using MacPostFactor (to be found in osxhackers.net) I managed in my MB early 2008 to install first Mavericks and then Yosemite. Some people reported to have even El Capitan running in such a machine but Yosemite was as far as I managed to go. I kept however Lion in a USB stick to have a Recovery Partition which was not possible to get because of the hacked Yosemite. It is needed for instance for a TimeMachine recovery if such an event becomes necessary.
    And needless to say make a bootable clone of your present inner drive and all your data (or replace it with a larger, preferably SSD drive), in case something you try does not work.

    Not everything works like in a supported Yosemite and compromises must be accepted.:rolleyes:
    For instance the brightness cannot be dimmed or changed with the brightness key and in order to see a video in .avi format I must use the HD video player which comes with the PTP application Vuze.

    Also when Apple issues an update, usually for safety reasons, I must run the Apple HDkext to be found in the OSX utilities folder belonging to the MacPostFactor installation. In that way I recover the sound in and sound out (built in mike and built in speakers) since any update issued by Apple takes the sound functions away.o_O
    And of course a bootable clone of this hacked Yosemite should be done from time to time in a USB external drive in case something goes wrong and the difficult installation procedure can be avoided by cloning back Yosemite from that clone.:)

    Using Bootcamp and after having installed a larger inner SSD drive and added some RAM to have a total of 6 GB which is the maximum my MB accepts, I installed in a part of the inner drive Windows 8.1 which I updated to Windows 10 but still having the "old" Win 10 version and not managing to install the Fall Creators Update.:mad:
    Since this is also the case in the Bootcamp Windows 10 of my MP 6.1, I believe it to be a problem of Windows running in a Mac and not specific to the MB 4.1.
    I suppose that if someone wants he could use this MB purely as a Windows 10 notebook.
    Some third party driver apps can be helpful for instance Driver Max helped me to find a Windows driver for the webcam iSight, but those driver apps must be used with caution and only if the drivers supplied with Bootcamp fail. In one case I lost the WiFi (!) because of Driver Max but luckily could revert in Windows to the previous working WiFi driver,

    To see a movie the Windows side delivers (for reasons I do not know) a much fluid rendering of a movie, particularly if it is a newer and larger file obtained from instance through torrents.

    Learn to accept compromises if you change anything from what Apple intended 10 years ago with that MB :oops:
    I learnt to live with the noise of the fan :oops: which blows almost always quite strongly particularly under Windows 10, I assume to cool the CPU since a SSD does not get hot.:rolleyes:
    You can feel in your hand when holding the MB the hot place where I presume the CPU is placed.
    The trackpad does not work in my Win 10 like under OSX so :oops: to scroll down I must use the scrolling "sides" of a window. Still compromises... o_O

    The main advantage in my case for the present OSX situation as compared to the initial state in which I bought it second hand a couple of years ago (for about $120) is to be able to run many applications needing at least Yosemite.;)
    Of course the SSD, a new battery and additional RAM more than doubled the buying price, but... show me a 10 year old Windows notebook still working!:confused:

    Be aware however that one needs a lot of patience with the MacPostFactor procedure, probably needing several attempts until one gets Yosemite or at least Mavericks.
    And in any case (AGAIN! I HAVE TO INSIST) :rolleyes: make BY ALL MEANS a bootable clone drive of your old OSX and all your data and CHECK :eek: that your MB 4.1 can actually BOOT from it :rolleyes: before trying anything else. In that way in the worst scenario you can get back to a working machine.

    Best regards and good luck to whatever you decide to do. :)
    Ed
     
  9. robo456 macrumors 6502

    robo456

    Joined:
    Mar 3, 2008
    Location:
    New Jersey
    #9
    I tried out this method for High Sierra http://dosdude1.com/highsierra/ on my Early 2009 "Whitebook". It did work, but I felt like I was almost 'hackintoshing' at that point, so I changed my mind and I think it was El Capitan I went back to to be 'official'.
     

Share This Page