Black screen with Sapphire Pulse Radeon RX 580 8GB on MacPro 2010

Discussion in 'Mac Pro' started by hendrik_ge, May 21, 2018.

  1. hendrik_ge, May 21, 2018
    Last edited: May 25, 2018

    hendrik_ge macrumors newbie

    Joined:
    May 21, 2018
    #1
    Hi Folks,
    I do have a 2010 Mac Pro with MacOS 10.13.4 running. Bootcamp is in place for a second hard drive and macOS harddrive has filevault.
    I bought a Sapphire Pulse Radeon RX 580 with 8GB but booting with this card just brings a black screen. No logon screen or anything else. It just brings two times the startup sound (about 10 seconds in between).
    Power is connect with one 6 pin to 8 pin cable.
    Do I need some drivers oder something else?
     
  2. flyinmac macrumors 68040

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #2
    Two things I’d consider exploring.

    If the card only has a single 8-pin connection on it, then I’d get a double 6-pin cable that combines to one 8-pin connection.

    I’d suspect that you’re currently underpowering the video card.

    If it has two 8-pin connections, then I’d say you’re out of luck.

    If power isn’t you’re problem, and your original Mac video card doesn’t require power leads, then I’d boot with both cards installed. And with a monitor on both cards.

    Then I’d make sure you had proper drivers downloaded and installed and that your new card is detected. Once you have video on that new card through it’s monitor, then try booting with only the new card installed.
    --- Post Merged, May 21, 2018 ---
    Also, a quick search turned up this link on the power cable theory.

    https://forums.macrumors.com/thread...ro-be-used-on-a-8-pin-gpu-like-a-770.1680079/
     
  3. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #3
    1) how you power the card?

    2) do you use FileVault?

    3) the cMP still working with another GPU?
     
  4. hendrik_ge thread starter macrumors newbie

    Joined:
    May 21, 2018
    #4
    Added a one 6 pin to 8 pin PCI adapter.

    yes.

    yes. Runs with a ATI Radeon HD 5870 1024 MB
    --- Post Merged, May 21, 2018 ---
    Will try to get one of the dual cables
     
  5. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    FileVault is the problem. You can’t use a RX580 with FileVault ON.

    Single mini 6pin to 8pin is NOT good enough, but won’t cause this black screen issue. However, it can shutdown your Mac when you stress it. You should use DUAL mini 6pin to single 8pin cable.
     
  6. orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #6
    i think if possible a dual 6 pin to 8 pin is worth doing to balance the power load, you will have to daisy chain some cables ie
    mac 6pin to pc 6pin (x2)
    to
    two pc 6 pin to 8 pin
    in to GPU
     
  7. MarkC426 macrumors 6502

    Joined:
    May 14, 2008
    Location:
    UK
    #7
    You can get just one cable, dual 6pin to 8pin :)
     
  8. hendrik_ge thread starter macrumors newbie

    Joined:
    May 21, 2018
    #8
    okay, will try disabeling FileVault and then try again with the rx580.
    Thanks for the help sofar.
     
  9. skizzo macrumors regular

    Joined:
    Apr 11, 2018
    #9
    You are going to need to still power it properly as others mentioned

    To not confuse anyone you actually mean dual MINI 6pin to 8pin. Yes there are dual mini 6pin to 8pin cables that everyone on here points to but I had one hell of a time finding a source for these that were not in China. Being in USA, having to wait 7 weeks shipping time for a $10 cable was not something I wanted to do.

    So as orph mentioned I got two individual mini 6pin to standard 6pin cables, and then a dual FEMALE 6pin to single 8pin MALE cable. This saved me from having to feel like eternity waiting on that single cable solution from China
     
  10. MarkC426 macrumors 6502

    Joined:
    May 14, 2008
    Location:
    UK
    #10
    I got mine from ebay (china), and had it in less than a week.
     
  11. orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #11
    hope it's working now :D im hoping the rx580 will be my next gpu once there not overpriced

    i had no idea there where min dual 6 pin to 8 pin :oops:
    who uses them ? apart from macpros
     
  12. hendrik_ge thread starter macrumors newbie

    Joined:
    May 21, 2018
    #12
    Worked well. FileVault is disabled and rx580 works. Thanks guys!
     
  13. crjackson2134 macrumors 68040

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #13
    Just out of curiosity, what causes the FileVault and RX 580 conflict.
     
  14. tu2thepoo macrumors member

    Joined:
    Nov 14, 2017
    #14
    from what I understand, the filevault login comes before the MacOS video drivers are fully loaded. So on cards that don't have a Mac EFI boot screen (basically any modern card), the login screen never displays. For some reason you can't even blind-type your Filevault password (I've tried).
     
  15. owbp macrumors 6502a

    owbp

    Joined:
    Jan 28, 2016
    Location:
    Belgrade, Serbia
    #15
    It's not the just the RX580, FireVault can't be used with regular (PC) GPU.
    You got to have Apple/Mac graphics for FireVault (or any flashed GPU for that matter).

    Edit: @tu2thepoo beat me to it.
     
  16. crjackson2134 macrumors 68040

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
  17. hendrik_ge thread starter macrumors newbie

    Joined:
    May 21, 2018
    #17
    Hi Folks,
    finally everythink went well. Thanks for the support.
     
  18. theone29 macrumors member

    theone29

    Joined:
    May 6, 2013
    #18
    Anyone got a link for the dual mini 6 pin to single 8 pin cable? thanks.
     
  19. MarkC426 macrumors 6502

    Joined:
    May 14, 2008
    Location:
    UK
    #19
    Just do a search on ebay for 16awg dual mini 6pin to 8pin pci-e for mac pro.
    I am in the UK but had to go through the US store to find it (shipped from China).
     
  20. theone29 macrumors member

    theone29

    Joined:
    May 6, 2013
    #20

    Thanks.
     
  21. theone29 macrumors member

    theone29

    Joined:
    May 6, 2013
    #21
    I have a 5,1. My MSI RX580 stops displaying today. I swapped it out with an R9-280X while waiting for the dual mini6-8pin. It was working prior with a 6-8pin. I upgraded to 10.13.5 while waiting for the cable. Got the cable, swapped the rx580 back in now I’m getting a black screen. But the R9-280X works. Any suggestions? Thank you.
     
  22. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #22
    The problem shouldn't be single or dual mini pin supply.

    If the RX580 draw too much on a single mini 6pin supply, the cMP should shutdown. But not kill the card.

    If nothing changed (same monitor, same setting, same cable...), but the RX580 suddenly stop working. Then I suspect your card is failed.

    If still has warranty, you should ask for RMA now.
     
  23. theone29 macrumors member

    theone29

    Joined:
    May 6, 2013
    #23
    Nothing changed. Do you think upgrading to 10.13.5 may have something to do with it? I can see the fan running on the RX580 but nothing but a black screen.
     
  24. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #24
    There is a small chance is OS related, especially if that's not a reference card.

    If it's OS released. Your RX580 should still able to boot other OS (e.g. Windows).

    If you don't have Windows, you can download the ISO from MS and run the installation disc (hold "C" during boot), no need to install anything, but just let the installer activate the RX580. If you can see anything, that means the card is working.

    Apart from Windows, you can also run a Linux LiveCD to verify if your RX580 is working.

    Or you may even try the recovery partition (holding Command + R to boot). But this is not an very accurate method, because the OS update may also update the recovery partition, make it lost your particular RX580's support.
     
  25. crjackson2134 macrumors 68040

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC

Share This Page