blacksn0w crashing your 3.1.2fw 05.11.07bb 3gs? No shsh? Solution!

Discussion in 'Jailbreaks and iOS Hacks' started by crazyfool2100, Mar 23, 2010.

  1. crazyfool2100 macrumors newbie

    Mar 8, 2010
    I found the solution to this common problem. I was so excited to have my unlock back, I had to share it:


    blacksn0w crashes 3.1.2 firmware 05.11.07 baseband 3GS, no shsh on file (Solution)

    Many have reported having a problem where blacksn0w works for a period of time on a 3.1.2 firmware 05.11.07 baseband 3GS, but then crashes and goes into a permanent boot loop. Upon restoration, blacksn0w no longer unlocks the phone, but rather the phone simply says “Searching…”, freezes, and enters into another boot loop. The problem seems to result from a corrupted baseband. Restoring with custom 3.1.2 firmware with blacksn0w included doesn’t fix it, nor does restoring with 3.1 and trying to blacksn0w.

    The problem should be fixed by a factory restore to 3.1.2 firmware, which will refresh the baseband to 05.11.07 and allow you to unlock the phone again. However, if you don’t have your 3.1.2 shsh on file, you cannot complete a factory restore and are stuck with custom jailbroken firmwares that don’t include baseband updates (only for non-tethered/old bootrom 3gs').

    Solution: Manually flash to the phone the 05.11.07 baseband update extracted from an official 3.1.2 3GS firmware. You don’t have to have your SHSH on file, but your phone has to be bootable. Use a custom 3.1.2 ipsw from pwnagetool to get up and running if you are still in the boot loop and dont have your shsh (only for old bootrom non-tethered 3gs'). If you are stuck in a recovery loop with a tethered jailbreak/new bootrom and don't have your 3.1.2 shsh on file, you may be out of luck getting back to 3.1.2.


  2. raysmd macrumors member

    Sep 4, 2007
    ok, I'll bite...

    I'm stuck in recovery loop and would like to get back to 3.1.2 (never upgraded to 3.1.3).

    How do you load the custom firmware with a 3GS and tethered jb?
  3. LisiFP macrumors newbie

    Feb 25, 2010
    well, did it and I'm still getting the 'no service' message where it should be my carrier...
    The weird thing is, it does get the full signal and my carrier's name the first 10 seconds and then disappears and it changes to 'no service'
    Anyone on the same boat?:eek:
  4. Kevinnijjar23 macrumors member

    Dec 20, 2008
  5. LisiFP macrumors newbie

    Feb 25, 2010
    by the way there are 4 files on the forlder

    There's 051107_bbupdate.md5
    what's that for?
  6. crazyfool2100 thread starter macrumors newbie

    Mar 8, 2010
    I think if you have a tethered jb (new bootrom) and dont have your shsh on file for 3.1.2, you may be out of luck restoring back to 3.1.2. If u do have ur shsh on file, there are many tutorials out there to guide you through restoring:
    "If you have an iPhone 3GS: PwnageTool works if you’re currently at version 3.1.2 or below (down to 3.0) and if you know you have a old bootrom. You don’t need to be already jailbroken — PwnageTool will ask you if you’re jailbroken after you’ve created the IPSW. Don’t use PwnageTool unless you know for sure you have an old bootrom (if you’re not sure, assume the worst and don’t use it)."

    Strange, it seems to be working for many others. Have you tried it a few times and rebooted?

    Don't worry about that, it's just to verify the integrity of the other 3 files.. google md5 hash if you want to know more.
  7. LisiFP macrumors newbie

    Feb 25, 2010

    I tried 4 times, 2 of them I did it restoring to custom firmware first then using diskaid I copied the files on my /tmp folder, then I used mobileTerminal, rebooted, opened cydia, installed blacksn0w, rebooted, inserted sim from my other phone, the carrier appeared for 10 seconds (the first time it was like 30 seconds and I cold actually make a call!:p) then is replaced by 'no service'.

    I don't think it's a hardware problem because it happened right after it got stuck on the apple logo... and I read I'm not the only one having problems..
    but since I flash my baseband and it still doesn't work then what could it be? does blacksn0w corrupt something else?
  8. crazyfool2100 thread starter macrumors newbie

    Mar 8, 2010
    Does it cause you to go into a boot loop after? Can you reboot your phone with blacksn0w installed after you refreshed ur bb?

    Try uninstalling blacksn0w and trying to install the Blacksn0w RC2 at cydia repo
  9. LisiFP macrumors newbie

    Feb 25, 2010
    nono, I only got the boot loop once, and the after I recovered from it my unlock wasn't working properly, gives me the no service msessage everytime,.
    I did try Blacksn0w RC2, and the first time I could make one phone call, but then the signal dropped.
    It's just weird, I want a dev team unlock!! :p
  10. tmatthews14 macrumors regular

    Feb 12, 2010
    I dont think this is working for me.
    So I uploaded all the files to /tmp
    I ran the first few lines of code okay, and after I enter the:
    launchctl unload /System/Library/LaunchDaemons/
    I lose service... seems normal.
    So I run the last line:
    ./BBUpdaterExtreme update -f ICE2_05.11.07.fls -e ICE2_05.11.07.eep
    But it seems like before it finishes my SSH program disconnects from the phone. My phone sits there with "searching..." until I reboot my phone.
    Is this normal? I'm still getting signal drop outs.
    Should I run those two lines of code on MobileTerminal to prevent the SSH program from disconnecting early?

    EDIT: I ran it on my phone and I got an error saying that CommCenter wasnt unloaded. Here's a picture.

    Attached Files:

  11. crazyfool2100 thread starter macrumors newbie

    Mar 8, 2010
    Did you reboot and try again? Or do you already have blacksn0w installed?
  12. tmatthews14 macrumors regular

    Feb 12, 2010
    I rebooted and tried again. Always the same thing.
    Blacksn0w was installed by the previous owner. I just recently restored to custom 3.1.2, but I'm still having the same problems. (because the jb didnt touch the bb)
    Nobody else had problems with this?
    I tried changing permisions on the CommCenter to 755, but still nothing.
  13. gottafly macrumors regular

    Aug 26, 2008
    I had a similar problem, after installing blacksn0w RC2, I would get "searching" for signal and nothing else. Also, wifi seemed to be disabled.

    I solved it by installing Fuzzyband and going from baseband 5.11.02 to the original 4.26.08 (all on 3.1.2). Simple as can be, and works great....and wifi is back on!

    I'm happy!

Share This Page