BootCamp won´t boot from External DVD - NON BOOTABLE DEVICE

Discussion in 'Windows, Linux & Others on the Mac' started by alex242, Dec 9, 2008.

  1. alex242 macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #1
    Due to internal Superdrive death, I bought an External DVD Drive, its LG DVD 5163D Firewire and USB, connected thru FW to my iMac 17 CoreDuo Early 2006 with Leopard 10.5.5

    I did the BootCamp partition below 32 GB, clic on Continue, system boot and a black NON BOOTABLE DEVICE, PRESS A KEY TO... screen shows. No matter what, it keeps showing this.
    I guess it could be my XPSP2 copy, but I did installed from same disc on this machine using Tiger and the internal Superdrive, back when it still works.
    I even did a FreeDOS system (someone says this could be the problem, XP won´t format the BOOTCAMP partition), black screen again, what drives me to start thinking that the problem is not with discs but the DVD Drive instead. I guess Leopard doesn´t likes my Drive. Worth to say, Leopard installed flawless from this Drive, and if trying to boot Leopard from CD works ok.

    Is there any way to force Leopard to boot from external DVD? (assuming this is the problem) Is there any know issues with 10.5 and booting from external DVD?
    Anyone goes thru this? I couln´t find any case like this.

    Please Help!
     
  2. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
  3. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #3
    I am experiencing the exact same problem. I don't know where the clue is.
    The weird thing is, that the bootcamp documentation says that it is possible to install windows from an external drive.
    And it isnt the problem of my windows xp cd, because i also tried a 32-bit Vista Oem CD. Same problem.
    My external drive (from LACIE) is connected through firewire. When I connect it through USB it does not recognize my CD. You just see a white screen.
    pressing Alt-Key and booting from here does not work. Neither with firewire connection nor with USB.
    My internal drive is screwed up So I just can use the external drive.
    to repair my internal drive it would cost more than 400 Euros , I already checked that. my mac is out of warranty. And I am not going to repair my internal drive, because the external works perfect.
     
  4. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #4


    I might try another drive, a Sony that's around my office. If I remember well, I think I'd installed XP from this drive, but over Tiger.
    You may consider get another drive, ask your friends for one.
    Good Luck
     
  5. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #5
    Well, I did it with the Sony Drive (DRX-720 UL) and same result: black DOS screen with same message. I give up.

    All I can do is blame Leopard for this. Under Tiger Bootcamp ran flawless.

    Please let me know if you can do something.

    good luck
     
  6. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #6
    hi, no I still havent found any solution. Im also giving up somehow..... I mean I could install TIger again but I don't want to beacause all in all I still like Leopard more.
    Im still searching on the net for a solution but I don't think theres a good one.

    THE WIERD THING IS THEY SAY IT IS POSSIBLE TO INSTALL IT FROM AN EXTERNAL DRIVE!
     
  7. WPB2 macrumors 6502a

    WPB2

    Joined:
    Jul 1, 2008
    Location:
    Southeast, LA
  8. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #8
    Could be my XP -original- copy? If I know this is the issue, I'll buy an original one, but I don't want to spend any money for nothing.
    Under Tiger the same disc worked fine.
     
  9. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #9

    No it's definitely not that. Ive tried Xp -Original- (since only this is Service Pack 2) , Xp Original, And Vista Original

    It normally works with -Original- CDs.

    It worked on Tiger? Are u sure? Did you install it using an usb optical drive or firewire?

    Because, shouldn't it work to make a third Partition to install Tiger than? And do everything from there and delete it later?

    I tried to install windows on my bootcamp partition using Parallels, but it didnt work for me. Parallels does only the virtual install. I don't know why.

    Im about to download any possible Software Update for my Leopard now, and try it then. Maybe 10.5.6 works with it?

    The weird thing is that it definitely should work for Macbook Air Users, since they say it on this page:

    http://support.apple.com/kb/HT2298


    This is really pisses me off! I mean I love Leopard and Apple! I just need Windows for playing Games and nothing else....

    Have you found something helpful so far?
     
  10. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #10
    No. I didnt found anything helpful yet.
    It's a good idea to install Tiger in another partition. I'll try this whenever I can.

    I did install this copy of XP under Tiger. I cant remember if I did it with the external drive or internal. I guess so.

    I baadly need to play Winning Eleven!!! And R/C simulators too!!!
     
  11. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #11


    MAN! IT WORKED! I EVEN DIDNT NEED TIGER FOR THIS!
    I still can't believe it but it really worked! And it works PERFECT!

    I don't know if I just had luck or something, but heres what I exactly did:


    At this Moment my external drive is connected with Firewire:

    1. I downloded all possible Updates for my Mac, that where found in Software Update: I was still running 10.5 so now I have 10.5.6

    2. I created a Bootcamp Partition with 60GB

    3.I inserted the Windows XP Service Pack 2 Install CD (U know which one that is if u read my post before)

    4. I restarted my system through Bootcamp.

    5. My system restarted and what showed up again: The Dos Text: NO bootable device.....

    6. Ok I turned off my System.

    7. I turned off my external Drive.

    8. I disconnected the Firewire Connection, and connected my external optical drive with USB. I took the Usb Dock which was nearest to the Power Connector.

    9. I turned on my optical drive.

    My optical Drive is now connected through USB:

    10. I turned on my Computer

    11. Directly after the Startup Sound that came, like a half or one second or so, or directly at the end of the sound (don't exactly know now..)
    I pressed the alt Key and let it pressed.

    12. Then what happend is this. After some second a black screen appeared.

    13. And then after the black screen The BLUE WINDOWS INSTALLER Installation Screen appeared (You can imagine how happy I was :D)

    14. It loaded evrything. I reformated my partition using NTFS (QUICK)

    15. After everything was done my computer restarted. And then nothing happened. Just a white Screen.

    16. So turned my computer off and on again, and pressed exactly when the sound came, the alt key to get into the boot menu of Apple,

    17. And here too Boot Selections Appeared: MAC OSX and WINDOWS!

    18. I selected Windows, and then everything went normal, the installer (with the XP design) started, and I was in Windows.

    19. Now I insterted my Leopard install Disk, and All the Bootcamp Drivers installed.

    20. I restarted my system and now it works just beautiful. (Everything with Airport and Isight, sound and graphics....)

    I even tried a game and it worked.

    So... this is what I exactly did, maybe there are some unnesacary steps but this is what happened and worked for me.
    So finally the USB connection worked. Maybe it was just because of my Update to 10.5.6 or because I pressed the alt-key.

    Try this out man, I hope it works for you. Tell me if it worked.

    Cheers
     
  12. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #12
    Good for you!

    I'm just a little reluctant to go into 10.5.6. That update just screw my iMac at work. Did you update from Softare Update or download the Combo Update?
    I'd realize my Bootcamp is 2.0, may be yours is 2.1 before the update?
    I'll try all this at home.
    Thanks
     
  13. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #13

    hey my bootcamp seems also to be 2.0


    let me know how it worked.
     
  14. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #14
    All Boot Camp Assistant applications are 2.0. The 2.1 Updater listed on the Boot Camp Support site is just a driver update package, not an update to the Boot Camp Assistant application itself.
     
  15. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #15
    XBENX I OWE YOU A BEER!!

    I did it w/o doing the upgrade and w/o doing the firewire first and didn´t worked, just a blank (grey) screen.

    So, I downloaded the Combo Update 10.5.6 (650mb) since using Software Update screwed a couple of things as I told before.

    Do the Bootcamp thing (30Gb), click on Start, boot, black screen, turn off everything, did USB connnection, startup and PRESTO!!! Magic happens!!

    I din´t do the whole installation, just to see the first blue window was enough for me. Due lack of time, I´ll do the full install later.

    Many, many thanks, this is when this forum s**t worth the time expended.
     
  16. xBenx macrumors newbie

    Joined:
    Dec 17, 2008
    #16
    Hehe im glad that it worked :D

    I see how happy u are, like me when it worked :) I spent hours in searching the net and trying several things of wasting my time with it.... I found this Forum when I did a google search and saw your post :D But this solution of installing windows was something I tried on my own without reading it anywhere, and see it worked.

    when this installer shows up the rest should work also, just remember when the installer restarts your computer again it may be not booting, but u have to choose it by yourself by pressing the alt-key. And remember putting in your Leopard CD for the Drivers when Windows is installed.

    Thanks for the beer I'll enjoy it ;)

    By the way I started playing games with windows and it works perfect. Even Windows is with my powerful Mac very fast and good.

    Cheers
     
  17. alex242 thread starter macrumors member

    Joined:
    Apr 6, 2006
    Location:
    Chile
    #17
    I bet your games run ok! Don't know what machine you have, but mine is the lowest intel iMac (early 2006, 17", 1.8Mhz) and run windows games smooth and fine. Now she has 2gb ram so I expecting even better performance.

    Good news keep coming; Tech Service accepted to change my screen for free (it has several vertical 1px lines, annoying) besides warranty expired.
     

Share This Page