booting OS 9 from FW drive?

Discussion in 'Macintosh Computers' started by sonofslim, Feb 11, 2004.

  1. sonofslim macrumors 6502a


    Jun 6, 2003
    G4 cube running Panther, external FW drive running 9.1. i'm trying to get the machine to boot into 9 from this FW drive, but every time i try i get the same result: blank grey screen, no icon indicating any of the usual drive errors. it's like it's freezing before before it gets to the happy-mac screen.

    both drives are proven to work. i've tried all the jumper settings on the external, with the same grey-screen results -- haven't monkeyed with the internal jumpers, though.

    two things that might bear mentioning:

    1) when i boot up and hold the option key, one of two things happens. if the boot startup disk is set to the internal (running panther), then that disk is displayed along with the usual reboot/continue buttons. if the FW drive is set as the startup volume, then no drives are displayed but the reboot/continue buttons are.

    however: in both cases, i get the OS 9 watch cursor that just ticks and ticks until i restart the machine. i can't continue or reboot in either instance.

    2) the firewire enclosure is new, and i'll admit it was kind of cheap.

    does anyone have any suggestions? is it even possible to boot into 9 from a FW drive?

  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    You should be able to boot Mac OS 9 from an external FireWire drive. Since you have Panther, check to see if Classic will load off the FireWire drive. If it doesn't load, then your Mac OS 9 install is corrupt. Try deleting some of the system preference files (like Finder prefs) and restarting Classic. If it still won't work, run a disk check on the FireWire drive. Directory corruption can prevent booting. If the disk appears to be OK, or booting Classic fails, try reinstalling Mac OS 9 on the FW drive. Your Mac OS 9 system might be corrupted. If Classic does start, the first thing I would try is a disk check. The Mac OS boot loader gets confused if it can't find the boot information because of a corrupt filesystem on the boot drive. Then I would try a Mac OS 9 reinstall. After all that, and no success? Someone else should step in in that case...

Share This Page