boring 3gs unlock problems again !

Discussion in 'iPhone' started by oldgit49, Feb 29, 2012.

  1. oldgit49 macrumors newbie

    Joined:
    Feb 29, 2012
    Location:
    west sussex UK
    #1
    Hello everyone, just joined up as I have my 1st iphone. Have looked through threads but still confused being older generation!
    Simply put I have
    3GS serial xx0396xxxxx, on 5.01 fw and 05.16.05 baseband which was updated by last owner. I have redsnowed and have cydia. Is there any way to unlock and retain GPS functionality ie: retain 05.16.05 or must I get ipad and is that risky?
    Sorry to bore you guys again with this but things change so fast you never know whats up to date. I(n return I may be able to help with common uk and jap car faults)
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Installing the iPad baseband is the only way to unlock the 3GS on 5.0.1. Since you're in the UK, your carrier may offer unlocks for iPhones.
     
  3. miragebg macrumors 6502a

    Joined:
    Mar 23, 2009
    #3
    Just be sure that your bootloader is the older one, otherwise after updating to 6.15.00 you will damage your baseband module. If this happen- you have to throw your phone away..
     
  4. oldgit49 thread starter macrumors newbie

    Joined:
    Feb 29, 2012
    Location:
    west sussex UK
    #4
    thanks

    thanks for your quick response on that.
    Is it better to go ipad baseband or can I downgrade firmware safely to one that works with 05.16.05 and still get good functionality and GPS.What would most iphone users do guys!
     
  5. miragebg macrumors 6502a

    Joined:
    Mar 23, 2009
    #5
    Just find out which bootloader you have on your phone. If I remember correctly if your phone is manufactured after 21st week of 2011 you definitely have newer version of bootloader and if you try to put iPad BB 6.15.00 on it- you will kill it.
     
  6. miragebg macrumors 6502a

    Joined:
    Mar 23, 2009
    #6

Share This Page