Bought iLife08 - iMovie wont work on my version of OSX?

Discussion in 'Mac Apps and Mac App Store' started by Jowin, Sep 13, 2008.

  1. Jowin macrumors newbie

    Joined:
    Jun 2, 2008
    #1
    Ok, so i bought iLife 08 and installed it. Garage band and other applications work but the one program i need - iMovie, doesn't! It says "You cannot use this version of the application iMovie with this version of Mac OS X."

    I have OSX so according to the system requirements it should work...??

    If anyone has any idea what i can do to get this to work i'd be very grateful!!

    Cheers, Owen
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Erm, the system requirements are a bit more than "any version of OSX". I'm sorry, but I feel you are intentionally misrepresenting the facts to cover your mistake.

    The full requirements are both on the box and on the website.

    Do you have an Intel CPU or fast enough G5 (not a G4 or G3) PPC processor?
     
  3. Father Jack macrumors 68020

    Father Jack

    Joined:
    Jan 1, 2007
    Location:
    Ireland
    #3
    iLife 08 requires OS X version 10.4.9 or later.

    It also requires QuickTime 7.2 or later.
     
  4. Jowin thread starter macrumors newbie

    Joined:
    Jun 2, 2008
    #4
    Sorry but i'm not intentionally misrepresenting facts, i'm new to macs. I didn't realise that there are different versions of OSX. I just saw "OS X" and thought, yep got that.

    I have a 2GHz Intel core duo..

    Looking at the requirements list again knowing OS X has different versions, it says v10.4.11 or later...Am i going to have to buy OS X version 10.4.11 or is there an update you can buy to update from 10.5.4, which is what i have, to 10.4.11?

    cheers for the help guys, i didn't expect a reply so soon!

    :)
     
  5. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #5
    10.5.4 is newer than 10.4.11 so you don't need to worry about that. Perhaps there is an updated needed to iMovie: try running Software Update...
     

Share This Page