bricked(?) 3gs w/ 3.0 firmware, not sure where to go from here

Discussion in 'Jailbreaks and iOS Hacks' started by manman, Jul 6, 2010.

  1. manman macrumors regular

    Joined:
    Aug 18, 2008
    #1
    I have done lots of jailbreaks, unlocks etc in the past and never had a problem, but this is the first time. I did a jailbreak on my 3gs w/ 3.0 firmware- and it actually went fine. I should have just left well enough alone, but I wanted to erase the data on the phone (and re-jailbreak if necessary).
    So I used the reset function in the iphone settings app, and that's where thigns started to go wrong. It wanted me to activate with itunes again at first, but somehow it just magically stopped asking me without me actually activating. Then I tried to jailbreak again using redsn0w 0.8, and although it reported successfull, it got hung up just before the end. After resetting the phone, now the phone turns on fine and is recognized by iTunes, but the only app I have is cydia, and it crashes whenever I try to load it.

    I have hte latest version of iTunes right now, and after trying (and learning it's not possible anymore) to restore to 3.0, I downloaded and tried to restore to 3.1, but it won't let me do that either. i get an "unknown error occurred (3194)" message. I also don't have any backed up ECID SHSH (and don't even really know what that is, just soemthing I found in reading about this).

    So basically the phone is recognized as having 3.0, but is in a messed up state. The goal, if possible, is to restore back to something I can jailbreak, then use pwnage tool to get a jailbroken ios4 upgrade & unlock.

    Can anyone give me an idea of where I can go from here to get back on track with that?... thanks

    Edit: rebooted into recovery mode, and was able to re-jailbreak. The jailbreak was fully successful this time, but i'm still showing the same issue. I can download/install things via icy, but cydia still crashes on load.
     
  2. mcdj macrumors G3

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #2
    a bricked phone will not turn on, is not recoverable/restorable/rebootable in any way/shape/form. please tell everyone you know to stop using the term bricked for a phone that turns on.

    a DFU restore in iTunes will have you up and running in no time.
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Your phone is not bricked, just locked up because you hit the erase button in settings.

    You cannot brick these new phones except for sudden hardware failure.
     
  4. manman thread starter macrumors regular

    Joined:
    Aug 18, 2008
    #4
    sorry, that's why I had that question mark there in the title... I know what bricking traditionally means with electronics, but never had a jailbreak go wrong before, so i didn't know what symptoms people where having when they used that word in relation to jailbreaking in the past.

    The problem with doing a normal or DFU restore in itunes is that it wants to upgrade me to ios4, which I (at least I assume) don't want since my goal is to have a jailbroken ios4. From what I've read, you can only get that if you start with an already jailbroken 3.0 or 3.1 etc, and use somethingl like pwnage tool to restore with a cooked 4.0.

    I can do the shift+click restore thing to choose which firmware file i want to restore from, but since apple is no longer signing anything but 4.0 I get a failure during the stag where it verifies my restore with apple server. I did try DFU mode, but I seemed to be only given the same options. Is there another way to restore from DFU where I don't need to upgrade/get verification from apple's servers?


    I got some advice on another forum that I can restore to the modified 4.0 via pwnagetool, which I'm thinking might actually work...since technically I DO have a jailbroken 3.0, it's just...otherwise screwed up. I'll give that a shot tonight if nothing else works
     

Share This Page