Bricked my 4S by restoring after jailbreak... Has anyone restored after jb'ing 4S???

Discussion in 'Jailbreaks and iOS Hacks' started by ap3604, Feb 9, 2012.

  1. ap3604 macrumors 68000

    Joined:
    Jan 11, 2011
    #1
    It's ok now since I got my phone replaced but dunno if this has happened to anyone else :confused:

    I jailbroke my 4S w/ the absinthe app on my computer, was enjoying my jailbreak and everything was fine except for a few random lock ups / reboots.

    Eventually I wanted to get my phone back to stock (since I could always jailbreak again at a later time as long as I don't update to 5.1), so I did a DFU restore through itunes and get the following error after it is restored and I go through the setup process:

    "Only compatible SIM cards from a supported carrier may be used to activate iPhone. Please insert the SIM card that came with your iPhone or visit a supported carriers store to receive a replacement SIM card"

    I went to the AT&T store and they give me a brand new sim card... no luck. It still gives the same error as above.

    So I tried doing a few more restores but had absolutely no luck and eventually just made an appointment w/ apple to get a replacement phone.

    Hopefully this is just me doing something wrong but has anyone else restored their phone since they jailbroke?
     
  2. hchavarria macrumors 6502

    Joined:
    Oct 8, 2008
    #2
    I was jail broken and decided to go back to stock, did a restore and no issues.
     
  3. macbookman83 macrumors 6502

    Joined:
    Jan 23, 2011
    Location:
    New York
    #3
    You might want to list all steps you took that led you to that error message.

    I jailbroke then had to do a restore and then re-jailbroke again all without any issues.
     
  4. 4Sid macrumors newbie

    Joined:
    Feb 2, 2012
    #4
    Weird. Faced no issues while jailbreaking and restoring the device.
     
  5. EngageWithRage macrumors 6502

    EngageWithRage

    Joined:
    Jan 30, 2012
    Location:
    Your girlfriend's house
  6. rKunda macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
    #6
    I did a restore last night and rejailbroke. Had trouble restoring (error 21). Had to mess around with my hosts files and do a DFU restore. Fixed it, but it was a pain ;)
     
  7. Abarth1200 macrumors regular

    Joined:
    Jun 26, 2010
    #8
    Wow you bricked your own iphone and expect Apple to foot the bil
     
  8. RolledUp20s macrumors regular

    Joined:
    Jun 14, 2011
    Location:
    Wrexham, North Wales
    #9
    I restored my 4S through itunes no problems. Then i jailbroke again as i found the stock iphone boring :)

    Did you buy the 4S direct from apple? As they come unlocked that way, maybe if you bought it from a network provider store, thats why it locked up? ...just a thought anyway.
     
  9. ninjaw95 macrumors 6502

    Joined:
    Nov 30, 2011
    #10
    if you go into DFU mode and restore from there to 5.01, Apple cant tell it was ever jailbroken so you should be fine if its under warranty
     
  10. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #11
    99.999 it's not bricked just have to undo what you did.. DFU mode works best. if you have issues and get an error once in dfu try another computer.
     
  11. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #12
    This has nothing to do with jailbreaking. There is a known issue regarding this SIM problem across all carriers. I know this because it happened to me.

    Besides the known issue there are two or three other reasons something like this can happen.

    I spent two full days (18 hours) at an Apple store while they worked on my issue.

    One of the problems Apple is having is that the boxes are being mislabeled as to what carrier the iPhone is meant for.

    One of the stores in my area had 7 new iPhones that we're supposed to be Sprint but in fact were Verizon.

    Surprisingly the phone can still be activated but when you restore you get the SIM error mentioned above.
     
  12. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #13
    By the way, you should test your replacement iPhone by doing a restore. If everything is right you should not see that error. If on the other hand you get the same SIM error you have to go back to Apple and they have to investigate your returns/exchanges/purchase history.
     
  13. Trey1984 macrumors regular

    Joined:
    Mar 5, 2011
    #14
    i had a error code, just clicked on tiny umbrella and turned cydia host files off and problem solved
     

Share This Page