Bringing MBP to Genius Bar - Questions related to HD

Discussion in 'MacBook Pro' started by Flobber88, Oct 30, 2009.

  1. Flobber88 macrumors regular

    Joined:
    Jun 19, 2007
    #1
    So my 2.2Ghz MBP is off to the genius bar on Monday. Nothing is showing up on the screen so looks like logic board/video card problem.

    My questions is, I upgraded my stock 160Gb hard drive to a 500Gb one back in April (everything went well and no problems). If I bring my MBP to Apple and they see that I replaced the HD, could/would they assume that my HD install damaged the surrounding components, or will they not focus on that if there isn't any physical damage to the hardware?
     
  2. OldMike macrumors 6502

    OldMike

    Joined:
    Mar 3, 2009
    Location:
    Dallas, TX
    #2
    When you are saying that nothing is showing up on the screen, do you mean that it is completely black or does it boot up into a light gray screen?

    I am having some issues with a MBP 13" and was going to post a new thread about it, but wanted to make sure we are not actually having the same problem...
     
  3. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #3
    Do you have the stock drive?

    I wouldn't even risk it; but thats just me. Clearly Apple won't know if you've been in the machine since there is no security tape, and if you do a good job with the screws no one will be the wiser, but a hd replace is still involved hardware wise with alot of damage that could be done, so I could see them blaming it on that.

    Worse case? Well worse would be you would get the machine back un repaired, but the funniest case would be if they returned your machine with the hard drive in a little baggie like they do for those who replace the ram and apple deems it to be problematic.
     
  4. jbrenn macrumors 6502a

    Joined:
    Aug 27, 2008
    #4
    it really depends on the genius some would blame the drive some blame nvidea. if you have the drive i would put it back in.
     
  5. OldMike macrumors 6502

    OldMike

    Joined:
    Mar 3, 2009
    Location:
    Dallas, TX
    #5
    Well I was able to resolve my problem (which may be similar to yours).

    I received my MacBook Pro 13" yesterday, along with 4 GB of memory from NewEgg. I had a spare WD 320 GB sitting on my desk, and figured I would throw it in the MacBook instead of shelling out more cash for a 500 GB.

    So after I install everything, I put the ten screws back in the MBP, connect the power supply and try booting.

    Nothing!

    Just a gray screen and nothing more. I was immediately a little put off, since I had just returned a DOA White MacBook the week before. I perused Apple's Support site and tried a number of things. Lo and Behold the good ol' Command + Option + P +R PRAM zap did the trick. After the second chime and restart the MBP came to life.

    Amazingly, the 320 GB drive held an image of 10.5 off of my iMac 2.8 - and it still booted to it without an issue. I was kind of surprised. I played around in 10.5 a little and debated sticking with 10.5 or installing 10.6 that came with the MBP. I decided to do a clean re-install so that I could play around with Snow Leopard (I was holding off from installing it on my iMac until I was completely satisfied with its stability, like after 10.6.2).

    I erased the 320 GB drive and did a clean install of Snow Leopard. Installed iLife and all the other apps I needed. I was feeling pretty good and really was impressed by the little 2.26's performance with 4 GB, even when running VMs in VMware Fusion. Feeling proud of myself I shutdown the MacBook and took a break.

    Upon returning, when booting up I was met with the same gray screen that I had originally been confronted with. WTF! I went from being pretty happy to deflated quickly. I got it booted up again by resetting the PRAM. It took me about 45 minutes to realize that the MBP would boot nicely, every time, if it were restarted. The issue was only when I shut it completely down and then tried booting up again.

    I ran the Hardware Diagnostics and it came back good. I figured if the hardware passed it must be software and had to be fixable. Apple's Support site, at this point, recommended re-installing the original Apple components, but I really didn't want to have to pull the memory and hard drive out, and reinstall the original hardware. I created another Snow Leopard Boot drive off of an 80 GB USB drive I had. I booted into it, from a complete shutdown, without issue! I felt like I was onto something... From the USB boot drive I tried repairing the internal 320 GB drive - which didn't fix the problem.

    I went back and read through the MacBook Pro EFI 1.7 Problem thread (which really needs to be stickied) found here:

    http://forums.macrumors.com/showthread.php?t=729883

    I downloaded EFI 1.6 and followed the directions on pages 12 and 13 of the thread. Used a USB 8 GB stick to install the EFI 1.6 Firmware, and booted off of it.

    Bingo - solved the problem. I can boot from a complete shutdown in less than 30 seconds now (timed from pressing the power button to having the login screen shown). I was amazed that it worked, and was pretty angry at Apple for not correcting such a widespread and easy to resolve issue.

    So now, my only issue is having to remember to tell the updater not to install the 1.7 update. Besides that I am very happy with my now zippy and stable MacBook Pro 13"

    Hope this might help! And I thank everyone who has contributed to the EFI 1.7 Problem thread (and especially for hosting the EFI 1.6 update on Rapid Share) - you guys saved me from tearing my hair out! MacRumors.com rules!
     
  6. Flobber88 thread starter macrumors regular

    Joined:
    Jun 19, 2007
    #6
    Thanks for the replies. OldMike: I think my issue is slightly different than yours as I have no video at all, external monitor or such. Glad to see you fixed the issue.

    I decided to spend the 30 minutes and exchange the HD with the original, just to be on the safe side. The genius told me they would be exchanging the logic board (faulty nVidia GPU is what I suspect) so hopefully should have it back by friday.
     

Share This Page